aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ruby-flex_rb/Makefile8
-rw-r--r--math/ruby-math3d/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/ruby-flex_rb/Makefile b/devel/ruby-flex_rb/Makefile
index ba9abd424d91..cf71f0711d53 100644
--- a/devel/ruby-flex_rb/Makefile
+++ b/devel/ruby-flex_rb/Makefile
@@ -24,6 +24,12 @@ INSTALL_TARGET= site-install
DOCS= README
EXAMPLES= examples/*.rb test*.rb
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
${RUBY} -i -pe 'gsub /-ansi\b/, ""' ${WRKSRC}/${RUBY_EXTCONF}
@@ -39,4 +45,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/ruby-math3d/Makefile b/math/ruby-math3d/Makefile
index 69f130bfdd97..d34da2b015da 100644
--- a/math/ruby-math3d/Makefile
+++ b/math/ruby-math3d/Makefile
@@ -20,6 +20,12 @@ USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-patch:
cd ${WRKSRC}; ${RUBY} -i -pe 'sub(/\r/, "")' *.[ch]
@@ -30,4 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/manual.jis ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>