aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.cvsignore2
-rw-r--r--misc/amanda-server/Makefile4
-rw-r--r--misc/amanda25-server/Makefile4
-rw-r--r--misc/amanda26-server/Makefile4
-rw-r--r--misc/amanda32-server/Makefile4
-rw-r--r--misc/instant-server/Makefile2
-rw-r--r--net-im/kpopup/Makefile2
-rw-r--r--net-im/linpopup/Makefile2
-rw-r--r--net/jags/Makefile2
-rw-r--r--net/lanbrowsing/Makefile2
-rw-r--r--net/prosearch/Makefile2
-rw-r--r--net/smb4k-kde4/Makefile2
-rw-r--r--net/smb4k/Makefile2
-rw-r--r--print/apsfilter/Makefile2
-rw-r--r--print/cups-samba/Makefile2
-rw-r--r--print/cups-smb-backend/Makefile2
-rw-r--r--security/saint/Makefile2
-rw-r--r--www/elinks/Makefile2
-rw-r--r--www/mod_ntlm2/Makefile2
-rw-r--r--www/sams/Makefile4
-rw-r--r--www/smb_auth/Makefile2
21 files changed, 25 insertions, 27 deletions
diff --git a/.cvsignore b/.cvsignore
deleted file mode 100644
index e408436f3bac..000000000000
--- a/.cvsignore
+++ /dev/null
@@ -1,2 +0,0 @@
-distfiles
-packages
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index dc50aab6298f..f4758a4ee31a 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -135,10 +135,10 @@ CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
-SAMBA_PORT?= samba34
+SAMBA_PORT?= samba36
BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
-CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
+CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
# If configure founds libcurl, automatically enabled it (with plist change).
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index ea735e792e29..d785424b37f2 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
WANT_PERL= yes
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
OPTIONS= GNUTAR "use GNU tar" on \
SSH "enable ssh-auth" off
@@ -143,7 +143,7 @@ PLIST_SUB+= PLOT='@comment '
.if defined (WITH_SAMBA)
BUILD_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
-CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
+CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
.if defined (WITH_MTX)
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index f8827413ffd5..0c6139e00380 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -125,10 +125,10 @@ CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
-SAMBA_PORT?= samba34
+SAMBA_PORT?= samba36
BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
-CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
+CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
.if defined (WITH_MTX)
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index aea5b24079ae..54c48c6cd6ab 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -132,10 +132,10 @@ CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
-SAMBA_PORT?= samba34
+SAMBA_PORT?= samba36
BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
-CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
+CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
# If configure founds libcurl, automatically enabled it (with plist change).
diff --git a/misc/instant-server/Makefile b/misc/instant-server/Makefile
index 0bb8bba1eb31..dda5814dbe55 100644
--- a/misc/instant-server/Makefile
+++ b/misc/instant-server/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/postfix:${PORTSDIR}/mail/postfix \
cnewsdo:${PORTSDIR}/news/cnews \
${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
# Don't let stupid programs ask for configuration.
diff --git a/net-im/kpopup/Makefile b/net-im/kpopup/Makefile
index 4e55af1cd67f..6aed0122cf5b 100644
--- a/net-im/kpopup/Makefile
+++ b/net-im/kpopup/Makefile
@@ -19,7 +19,7 @@ COMMENT= KDE program for sending and receiving MS Windows WinPopup messages
RUN_DEPENDS= smbclient:${PORTSDIR}/${SAMBA_PORT}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
SUB_FILES= pkg-message
diff --git a/net-im/linpopup/Makefile b/net-im/linpopup/Makefile
index 9eee7f7a3704..456366ec2ddb 100644
--- a/net-im/linpopup/Makefile
+++ b/net-im/linpopup/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/smbclient:${PORTSDIR}/${SAMBA_PORT}
WRKSRC= ${WRKDIR}/LinPopUp-${PORTVERSION}/src
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
USE_XORG= x11 xmu
USE_GNOME= gtk12
diff --git a/net/jags/Makefile b/net/jags/Makefile
index 77b7f76827d3..36d39aa69f12 100644
--- a/net/jags/Makefile
+++ b/net/jags/Makefile
@@ -16,7 +16,7 @@ COMMENT= JAGS - Just Another GTK+ Samba Client
RUN_DEPENDS= smbclient:${PORTSDIR}/${SAMBA_PORT}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
CONFLICTS= jags-1.*
diff --git a/net/lanbrowsing/Makefile b/net/lanbrowsing/Makefile
index 5de2bdab5b1f..219cacf63d49 100644
--- a/net/lanbrowsing/Makefile
+++ b/net/lanbrowsing/Makefile
@@ -20,7 +20,7 @@ COMMENT= Lanbrowsing facility and backend for KDE
RUN_DEPENDS= nmblookup:${PORTSDIR}/${SAMBA_PORT}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
DEPRECATED= Depends on QT3; unmaintained
EXPIRATION_DATE= 2013-07-01
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index 77c63a73b526..82c2cc9505f0 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -17,7 +17,7 @@ NO_BUILD= yes
SEARCHDIR?= www/search
PLIST_SUB+= SEARCHDIR=${SEARCHDIR}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
USE_PERL5_RUN= YES
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index d30111701e1c..07fdacc65c98 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -19,7 +19,7 @@ COMMENT= KDE 4.x SMB Network browser and SMB shares mounting center
RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
smbstatus:${PORTSDIR}/${SAMBA_PORT}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
USE_CMAKE= yes
USE_GETTEXT= yes
diff --git a/net/smb4k/Makefile b/net/smb4k/Makefile
index 6bf8b9c6c9ab..5ca48c81e4d3 100644
--- a/net/smb4k/Makefile
+++ b/net/smb4k/Makefile
@@ -18,7 +18,7 @@ COMMENT= KDE 3.x SMB Network browser and SMB shares mounting center
RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
smbstatus:${PORTSDIR}/${SAMBA_PORT}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
USE_KDEBASE_VER= 3
USE_GMAKE= yes
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index 2f7297e8847f..97af12a346df 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -20,7 +20,7 @@ USE_SUBMAKE= yes
SUB_FILES+= pkg-message
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
# special arrangement for package building, build stuff without X11
# to make memory footprint of apsfilter package smaller
diff --git a/print/cups-samba/Makefile b/print/cups-samba/Makefile
index 8cabaeafee5b..1bc768c821ae 100644
--- a/print/cups-samba/Makefile
+++ b/print/cups-samba/Makefile
@@ -21,7 +21,7 @@ COMMENT= The Common UNIX Printing System: MS Windows client drivers
RUN_DEPENDS= smbspool:${PORTSDIR}/${SAMBA_PORT} \
${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/print/cups-smb-backend/Makefile b/print/cups-smb-backend/Makefile
index 3198ac27926a..5935498b1531 100644
--- a/print/cups-smb-backend/Makefile
+++ b/print/cups-smb-backend/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= smbspool:${PORTSDIR}/net/${SAMBA_PORT} \
NO_BUILD= yes
PLIST_FILES= libexec/cups/backend/smb
-SAMBA_PORT?= samba34
+SAMBA_PORT?= samba36
SUB_FILES= pkg-message
do-install:
diff --git a/security/saint/Makefile b/security/saint/Makefile
index ec5a23615087..b933491c40c9 100644
--- a/security/saint/Makefile
+++ b/security/saint/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= nmap:${PORTSDIR}/security/nmap
BUILD_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
.endif
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
USE_PERL5= yes
MANCOMPRESSED= no
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index a1fb7421f8f3..eeee09258773 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -23,7 +23,7 @@ USE_OPENSSL= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
MAN1= elinks.1
MAN5= elinkskeys.5 elinks.conf.5
diff --git a/www/mod_ntlm2/Makefile b/www/mod_ntlm2/Makefile
index 07ca5f476b27..333bf3a68f8e 100644
--- a/www/mod_ntlm2/Makefile
+++ b/www/mod_ntlm2/Makefile
@@ -14,7 +14,7 @@ COMMENT= NTLM authentication module for the Apache2 webserver
BUILD_DEPENDS= smbclient:${PORTSDIR}/${SAMBA_PORT}
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
MAKE_JOBS_SAFE= yes
diff --git a/www/sams/Makefile b/www/sams/Makefile
index 5be615c02485..d7e7ac19d18d 100644
--- a/www/sams/Makefile
+++ b/www/sams/Makefile
@@ -18,12 +18,12 @@ COMMENT= Squid 2.x Accounting Management System
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
USE_RC_SUBR= sams
OPTIONS_DEFINE= APACHE NTLM GD
-OPTIONS_DEFAULT=GD
+OPTIONS_DEFAULT=GD
INSTALLGD_DESC= Graphic reports
diff --git a/www/smb_auth/Makefile b/www/smb_auth/Makefile
index e049512524c1..61b9840dcf43 100644
--- a/www/smb_auth/Makefile
+++ b/www/smb_auth/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/${SAMBA_PORT}
.endif
ALL_TARGET= smb_auth
-SAMBA_PORT?= net/samba34
+SAMBA_PORT?= net/samba36
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/smb_auth ${PREFIX}/bin