aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/packagekit/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index b9a3113db324..6f731bc261fc 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -15,10 +15,14 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/docbook2man:${PORTSDIR}/textproc/docbook-utils
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libpolkit-gobject-1.so:${PORTSDIR}/sysutils/polkit \
libck-connector.so:${PORTSDIR}/sysutils/consolekit
-RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
-
-USES= execinfo gettext gmake iconv libtool pathfix pkgconfig \
- python:build shared-mime-info
+RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof \
+ bash:${PORTSDIR}/shells/bash
+
+USES= cpe execinfo gettext gmake iconv libtool pathfix pkgconfig \
+ python:build shared-mime-info shebangfix
+CPE_VENDOR= packagekit_project
+SHEBANG_FILES= backends/test/helpers/search-name.sh \
+ contrib/cron/packagekit-background.cron
USE_GNOME= glib20 intltool introspection
USE_SQLITE= 3
USE_LDCONFIG= yes