aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/efl/Makefile8
-rw-r--r--devel/google-perftools/Makefile7
-rw-r--r--graphics/blender/Makefile8
-rw-r--r--lang/ponyc/Makefile6
-rw-r--r--net-p2p/monero-cli/Makefile6
-rw-r--r--net/tigervnc/Makefile8
-rw-r--r--science/rubygem-ruby-dcl/Makefile6
-rw-r--r--www/rubygem-passenger/Makefile1
-rw-r--r--x11-toolkits/rubygem-tk/Makefile2
9 files changed, 37 insertions, 15 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index 120bfa99fcb7..3414590102c7 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libdbus-1.so:devel/dbus \
- libsndfile.so:audio/libsndfile \
- libunwind.so:devel/libunwind
+ libsndfile.so:audio/libsndfile
# lib/libeio.so.1
CONFLICTS_INSTALL= libeio
@@ -170,6 +169,11 @@ CONFIGURE_ARGS+= --disable-ibus --with-glib=no
CONFIGURE_ARGS+= --with-opengl=none
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
USES+= lua
CONFIGURE_ARGS+= --enable-lua-old
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index 8a3aa103542b..57e28e9d6ba2 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -18,8 +18,6 @@ BROKEN_powerpc= fails to build: assembly not supported, see PR\#94: http://code
BROKEN_powerpc64= fails to build: assembly not supported, see PR\#94: http://code.google.com/p/google-perftools/issues/detail?id=94&can=1
BROKEN_sparc64= fails to build: assembly not supported, see PR\#94: http://code.google.com/p/google-perftools/issues/detail?id=94&can=1
-LIB_DEPENDS= libunwind.so:devel/libunwind
-
DOCSDIR= ${PREFIX}/share/doc/gperftools
USES= compiler gmake libtool
@@ -64,6 +62,11 @@ CXXFLAGS+= -fno-builtin
CONFIGURE_ARGS+=--enable-frame-pointers
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
post-build:
@${ECHO}
@${ECHO} "Please run 'make check' (requires bash)."
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 207a7f0ecc74..111b757ed6b4 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -47,6 +47,14 @@ OPTIONS_SUB= yes
.include "${.CURDIR}/Makefile.options"
+# libunwind is specific to amd64/i386
+OPTIONS_EXCLUDE_aarch64= CAMERATRACK
+OPTIONS_EXCLUDE_armv6= CAMERATRACK
+OPTIONS_EXCLUDE_armv7= CAMERATRACK
+OPTIONS_EXCLUDE_powerpc= CAMERATRACK
+OPTIONS_EXCLUDE_powerpc64= CAMERATRACK
+OPTIONS_EXCLUDE_powerpcspe= CAMERATRACK
+
ALEMBIC_CMAKE_BOOL= WITH_ALEMBIC
ALEMBIC_LIB_DEPENDS= libAlembic.so:graphics/alembic
# note that this needs to be set to match alembics hdf5 option
diff --git a/lang/ponyc/Makefile b/lang/ponyc/Makefile
index 51dae6c00469..20c95ecf85f5 100644
--- a/lang/ponyc/Makefile
+++ b/lang/ponyc/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= Undefined reference to __atomic_compare_exchange_8
-LIB_DEPENDS= libunwind.so:devel/libunwind
BUILD_DEPENDS= llvm-link${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
RUN_DEPENDS= llvm-link${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
@@ -54,6 +53,11 @@ PONYARCH?= armv8-a
PONYARCH?= core2
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085
MAKE_ENV+= default_ssl=openssl_1.1.0
.endif
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 9e07fb1ac5c6..b80a4f987e84 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -35,7 +35,6 @@ LIB_DEPENDS= \
libpgm.so:net/openpgm \
libsodium.so:security/libsodium \
libunbound.so:dns/unbound \
- libunwind.so:devel/libunwind \
libzmq.so:net/libzmq4
BUILD_DEPENDS= ${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson \
${LOCALBASE}/include/zmq.hpp:net/cppzmq
@@ -80,6 +79,11 @@ CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
.endif
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
CMAKE_ARGS+= -DMANUAL_SUBMODULES:BOOL=ON
USE_RC_SUBR= monerod
diff --git a/net/tigervnc/Makefile b/net/tigervnc/Makefile
index 0ee4d71ae0f1..1b2962b9a9c0 100644
--- a/net/tigervnc/Makefile
+++ b/net/tigervnc/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/mesa-dr
${LOCALBASE}/libdata/pkgconfig/fontutil.pc:x11-fonts/font-util \
${LOCALBASE}/include/FL/Fl.H:x11-toolkits/fltk \
bash:shells/bash
-LIB_DEPENDS= libunwind.so:devel/libunwind \
- libxshmfence.so:x11/libxshmfence \
+LIB_DEPENDS= libxshmfence.so:x11/libxshmfence \
libfontconfig.so:x11-fonts/fontconfig
# almost equivalent to x11-servers/xorg-server's
RUN_DEPENDS= ${LOCALBASE}/share/X11/xkb/rules/base:x11/xkeyboard-config \
@@ -108,6 +107,11 @@ CONFIGURE_ARGS+= \
.include <bsd.port.pre.mk>
+# keep in sync with all platforms where libunwind is available
+.if (${ARCH} == amd64 || ${ARCH} == i386)
+LIB_DEPENDS+= libunwind.so:devel/libunwind
+.endif
+
TIGERVNC_XORG_PATCH_VER= ${MAKE} -C "${PORTSDIR}/x11-servers/xorg-server" -V PORTVERSION:R:S,\.,,g
# import from x11-server/xorg-server/Makefile
diff --git a/science/rubygem-ruby-dcl/Makefile b/science/rubygem-ruby-dcl/Makefile
index ca8982c90329..af0fe9ef40af 100644
--- a/science/rubygem-ruby-dcl/Makefile
+++ b/science/rubygem-ruby-dcl/Makefile
@@ -15,15 +15,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= rubygem-narray>=0.5.5:math/rubygem-narray
LIB_DEPENDS= libcdcl.so:science/cdcl \
libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libunwind.so:devel/libunwind
+ libfreetype.so:print/freetype2
RUN_DEPENDS= rubygem-narray>=0.5.5:math/rubygem-narray \
rubygem-narray_miss>0:math/rubygem-narray_miss
+USES= gem gettext-runtime
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
USE_XORG= ice sm x11
-
USE_RUBY= yes
-USES= gem gettext-runtime
.include <bsd.port.mk>
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index d51cedd4124b..fe7bfcdf6850 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -42,7 +42,6 @@ SHEBANG_FILES= src/cxx_supportlib/vendor-copy/libuv/gyp_uv.py
LIB_DEPENDS+= libuv.so:devel/libuv \
libcurl.so:ftp/curl \
- libunwind.so:devel/libunwind \
libapr-1.so:devel/apr1
BUILD_DEPENDS+= rubygem-rack>=0:www/rubygem-rack
diff --git a/x11-toolkits/rubygem-tk/Makefile b/x11-toolkits/rubygem-tk/Makefile
index ff6c3a19cf13..88331581740a 100644
--- a/x11-toolkits/rubygem-tk/Makefile
+++ b/x11-toolkits/rubygem-tk/Makefile
@@ -10,8 +10,6 @@ COMMENT= Ruby interface to TclTk-8.6
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libunwind.so:devel/libunwind
-
CONFIGURE_ARGS=--with-tcltkversion=8.6,8.6 \
--with-tk-include=${LOCALBASE}/include/tk8.6 \
--with-tcl-include=${LOCALBASE}/include/tcl8.6