aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-plog/Makefile28
-rw-r--r--security/p5-plog/distinfo3
-rw-r--r--security/p5-plog/pkg-descr7
4 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1f046b94e0c0..1f5ff62cf9fe 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -740,6 +740,7 @@
SUBDIR += p5-dicewaregen
SUBDIR += p5-openxpki
SUBDIR += p5-openxpki-i18n
+ SUBDIR += p5-plog
SUBDIR += pad
SUBDIR += pam-modules
SUBDIR += pam-mysql
diff --git a/security/p5-plog/Makefile b/security/p5-plog/Makefile
new file mode 100644
index 000000000000..9658a424521e
--- /dev/null
+++ b/security/p5-plog/Makefile
@@ -0,0 +1,28 @@
+# Created by: Cy Schubert <cy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= plog
+PORTVERSION= 0.10
+CATEGORIES= security perl5
+PKGNAMEPREFIX= p5-
+MASTER_SITES= http://www.antibozo.net/ogata/webtools/
+DISTFILES= plog.pl
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Perl based ipfilter log reporter
+
+USES= perl5 shebangfix
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+NO_BUILD= yes
+SHEBANG_FILES= ${WRKSRC}/plog.pl
+PLIST_FILES= bin/plog.pl
+
+pre-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/plog.pl ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/p5-plog/distinfo b/security/p5-plog/distinfo
new file mode 100644
index 000000000000..9e64a198cd4c
--- /dev/null
+++ b/security/p5-plog/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517109376
+SHA256 (plog.pl) = eb25970253e0726c0e471e32daab07c08ba6efde31894f57a0e0c943ccb3213a
+SIZE (plog.pl) = 29165
diff --git a/security/p5-plog/pkg-descr b/security/p5-plog/pkg-descr
new file mode 100644
index 000000000000..22d898443fb3
--- /dev/null
+++ b/security/p5-plog/pkg-descr
@@ -0,0 +1,7 @@
+plog is a parser for the logged output of the ipmon utility that is part
+of the excellent IP-Filter packet-filtering and NAT package written and
+maintained by Darren Reed. plog translates the somewhat garbled output
+from ipmon into a report that aids analysis of your firewall traffic.
+The current version number is 0.10.
+
+WWW: http://www.antibozo.net/ogata/webtools/