aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/gone/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/misc/gone/Makefile b/misc/gone/Makefile
index cf3d1d5e9876..16a053dcc583 100644
--- a/misc/gone/Makefile
+++ b/misc/gone/Makefile
@@ -9,14 +9,12 @@ MASTER_SITES= http://www.marcuscom.com/downloads/gone/
MAINTAINER= marcus@FreeBSD.org
COMMENT= A terminal locking utility with many improvements over lock(1)
-MAN1= gone.1
-PLIST_FILES= bin/gone
+PLIST_FILES= bin/gone man/man1/gone.1.gz
GNU_CONFIGURE= yes
OPTIONS_DEFINE= SETUID
SETUID_DESC= Install gone setuid root for password support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
@@ -31,4 +29,8 @@ CONFIGURE_ENV= with_setuid=yes
CONFIGURE_ENV= with_setuid=no
.endif
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gone ${STAGEDIR}${PREFIX}/bin/gone
+ ${INSTALL_DATA} ${WRKSRC}/gone.1 ${STAGEDIR}${PREFIX}/man/man1/gone.1
+
.include <bsd.port.post.mk>