aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/uhexen/Makefile4
-rw-r--r--graphics/swfdec/Makefile8
-rw-r--r--multimedia/xmps/Makefile8
-rw-r--r--net/tightvnc/Makefile4
-rw-r--r--net/vnc/Makefile8
5 files changed, 29 insertions, 3 deletions
diff --git a/games/uhexen/Makefile b/games/uhexen/Makefile
index f35f4638be85..6205ed12a80a 100644
--- a/games/uhexen/Makefile
+++ b/games/uhexen/Makefile
@@ -27,6 +27,10 @@ USE_GMAKE= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.if defined(WITH_NOWAD)
WITHOUT_WAD= yes
.endif
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index e0c412307d00..1f7ee4632fb9 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -30,8 +30,14 @@ INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG:T}|g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|g" ${WRKSRC}/libswfdec/jpeg/sl_types.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
index c4c5d7253881..2318ddaef72b 100644
--- a/multimedia/xmps/Makefile
+++ b/multimedia/xmps/Makefile
@@ -25,6 +25,12 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -34,4 +40,4 @@ post-configure:
@${REINPLACE_CMD} -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index e7c06f0eddb6..585f879cfa87 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -32,6 +32,10 @@ MAN1= Xvnc.1 vncviewer.1 vncpasswd.1 vncconnect.1 vncserver.1
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.if ${XFREE86_VERSION} >= 4
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/misc/10x20.pcf.gz:${PORTSDIR}/x11-fonts/XFree86-4-fontDefaultBitmaps
.endif
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index 5625ccd2ab28..93898bff8cf4 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -38,6 +38,12 @@ ${X11BASE}/lib/X11/fonts/misc/6x13-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/XFree8
USE_PERL5_RUN= yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-build:
.if !defined(WITHOUT_SERVER)
@${ECHO_MSG} "NOTE:"
@@ -96,4 +102,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/vncpasswd/vncpasswd.man ${PREFIX}/man/man1/vncpasswd.1
${INSTALL_MAN} ${WRKSRC}/vncconnect/vncconnect.man ${PREFIX}/man/man1/vncconnect.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>