aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/python.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/python.mk')
-rw-r--r--Mk/Uses/python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index ff7f14d0e9a0..8a7a9cfce0e2 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -614,7 +614,7 @@ add-plist-pymod:
# When Python version is 3.2+ we rewrite all the filenames
# of TMPPLIST that end with .py[co], so that they conform
# to PEP 3147 (see https://www.python.org/dev/peps/pep-3147/)
-PYMAGICTAG= ${PYTHON_CMD} -c 'import imp; print(imp.get_tag())'
+PYMAGICTAG= ${PYTHON_CMD} -c 'import sys; print(sys.implementation.cache_tag)'
_USES_stage+= 935:add-plist-python
add-plist-python:
@${AWK} '\