aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 40636247826f..77d5964bdada 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -155,6 +155,18 @@ NOPORTEXAMPLES= yes
WITHOUT_NLS= yes
.endif
+.if defined(NO_OPTIONS_SORT)
+_SORTED_OPTIONS:= ${ALL_OPTIONS}
+ALL_OPTIONS:=
+.for opt in ${OPTIONS_DEFINE}
+.if ${_SORTED_OPTIONS:M${opt}}
+ALL_OPTIONS+= ${opt}
+.endif
+.endfor
+.undef opt
+.undef _SORTED_OPTIONS
+.endif
+
### to be removed once old OPTIONS disappear
.for opt in ${ALL_OPTIONS}
.if empty(PORT_OPTIONS:M${opt})