aboutsummaryrefslogtreecommitdiffstats
path: root/Tools/scripts/rmport
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/scripts/rmport')
-rwxr-xr-xTools/scripts/rmport2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tools/scripts/rmport b/Tools/scripts/rmport
index 92e4f2cb6376..8da23c47071d 100755
--- a/Tools/scripts/rmport
+++ b/Tools/scripts/rmport
@@ -109,7 +109,7 @@ find_expired()
EXPVAR=EXPIRATION_DATE
find -H ${PORTSDIR} -mindepth 3 -maxdepth 3 -name "Makefile*" \
- |xargs grep -H ${EXPVAR} \
+ |xargs grep -H "^[^#]*${EXPVAR}" \
|sed -E "s|${PORTSDIR}/?([^/]+/[^/]+)/Makefile:${EXPVAR}=[[:space:]]*([0-9-]{10})$|\2 \1|g" \
|perl -ne "if ((substr(\$_, 0, 10) cmp '${TODAY}') <= 0) { print(\$_); }" \
|while read expdate catport ; do \