aboutsummaryrefslogtreecommitdiffstats
path: root/astro/py-horoscopegenerator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/py-horoscopegenerator/Makefile')
-rw-r--r--astro/py-horoscopegenerator/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
new file mode 100644
index 000000000000..16c7ee1c8afe
--- /dev/null
+++ b/astro/py-horoscopegenerator/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= horoscopegenerator
+PORTVERSION= 0.1.8
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+DISTNAME= ${PORTNAME:S/h/H/:S/g/G/}-${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Generate horoscopes using context-free grammar
+
+LICENSE= MIT
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk
+
+.include <bsd.port.mk>