aboutsummaryrefslogtreecommitdiffstats
path: root/astro/roadmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/roadmap/Makefile')
-rw-r--r--astro/roadmap/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index 2913449f93cd..8671a421d68d 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -6,41 +6,40 @@
#
PORTNAME= roadmap
-PORTVERSION= 1.0.r6
-PORTREVISION= 1
+PORTVERSION= 1.0.6
CATEGORIES= astro
-MASTER_SITES= http://roadmap.saignon.net/roadmap/
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}_1_0rc6_src
+MASTER_SITES= http://roadmap.digitalomaha.net/roadmap/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/rc/:S/./_/g}_src
MAINTAINER= nick@netdot.net
COMMENT= Vector-based GPS moving map
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ sqlite.2:${PORTSDIR}/databases/sqlite
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
USE_GNOME= gtk12
-
-USE_GMAKE=yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
BINS= buildmap buildus dumpmap
GUI_BINS= gtkroadmap gtkroadgps
SCRIPTS= rdmdownload rdmgetall rdmgenmaps rdmcompare
DATA= sprites preferences schema
-DOCS= AUTHORS BUGS COPYING README TODO
+PORTDOCS= AUTHORS BUGS README TODO
do-install:
.for _GUI_BIN in ${GUI_BINS}
- ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/gtk/${_GUI_BIN} ${X11BASE}/bin/${_GUI_BIN}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/gtk/${_GUI_BIN} ${PREFIX}/bin/${_GUI_BIN}
.endfor
.for _BIN in ${BINS}
- ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${_BIN} ${LOCALBASE}/bin/${_BIN}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${_BIN} ${PREFIX}/bin/${_BIN}
.endfor
.for _SCRIPT in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${INSTALL_WRKSRC}/${_SCRIPT} ${LOCALBASE}/bin/${_BIN}
+ ${INSTALL_SCRIPT} ${INSTALL_WRKSRC}/${_SCRIPT} ${PREFIX}/bin/${_BIN}
.endfor
${MKDIR} ${DATADIR}
.for _DATA in ${DATA}
@@ -48,7 +47,7 @@ do-install:
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for _DOC in ${DOCS}
+.for _DOC in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${_DOC} ${DOCSDIR}/${_DOC}
.endfor
.endif