aboutsummaryrefslogtreecommitdiffstats
path: root/astro/squeuer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/squeuer/Makefile')
-rw-r--r--astro/squeuer/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/astro/squeuer/Makefile b/astro/squeuer/Makefile
index e1f4498489ee..5ac34672a3b7 100644
--- a/astro/squeuer/Makefile
+++ b/astro/squeuer/Makefile
@@ -20,6 +20,8 @@ USE_PERL5_RUN= yes
MAN8= squeuer.8
MAN5= squeuer.conf.5
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
# These must be writeable by the user "squeuer"
SPOOLDIR?= /var/spool/squeuer
LOGDIR?= /var/spool/squeuer
@@ -32,6 +34,8 @@ do-configure:
-e "s:%%LOGDIR%%:${LOGDIR}:g" \
-e "s:%%PIDDIR%%:${PIDDIR}:g" $$i; \
done
+ ${SED} -e "s:%%LOCALBASE%%:${LOCALBASE}:g" \
+ ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/squeuer.pl ${PREFIX}/sbin/squeuer