aboutsummaryrefslogtreecommitdiffstats
path: root/astro/stardates/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/stardates/Makefile')
-rw-r--r--astro/stardates/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/stardates/Makefile b/astro/stardates/Makefile
new file mode 100644
index 000000000000..129860299338
--- /dev/null
+++ b/astro/stardates/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: stardates
+# Date created: 15 September 2005
+# Whom: freebsd-ports@henrik.synth.no
+#
+# $FreeBSD$
+#
+
+PORTNAME= stardates
+PORTVERSION= 1.6.1
+CATEGORIES= astro
+MASTER_SITES= ftp://ftp.cc.umanitoba.ca/startrek/stardates-pgms/ \
+ http://trek.starshine.org/downlink/utilities/ \
+ http://trek-stage.parts-unknown.org/downlink/
+
+MAINTAINER= freebsd-ports@henrik.synth.no
+COMMENT= Displays date in 5 formats (including stardate of course)
+
+MAN1= stardate.1
+PLIST_FILES= bin/stardate
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/stardate.c -o ${WRKSRC}/stardate
+
+do-install:
+ ${INSTALL} ${WRKSRC}/stardate ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/stardate.1 ${MAN1PREFIX}/man/man1/stardate.1
+
+.include <bsd.port.mk>