aboutsummaryrefslogtreecommitdiffstats
path: root/astro/stars/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/stars/Makefile')
-rw-r--r--astro/stars/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/astro/stars/Makefile b/astro/stars/Makefile
index 5acf8ea45079..c027c854090e 100644
--- a/astro/stars/Makefile
+++ b/astro/stars/Makefile
@@ -8,9 +8,8 @@
PORTNAME= stars
PORTVERSION= 1.0
CATEGORIES= astro
-MASTER_SITES= ftp://ftp.planetmirror.com/pub/hpfreeware/X11/Demos/stars-1.0/ \
- http://public.www.planetmirror.com/pub/hpfreeware/X11/Demos/stars-1.0/
-DISTNAME= stars-1.0-ss-11.00
+MASTER_SITES= http://hpux.connect.org.uk/ftp/hpux/X11/Demos/${PORTNAME}-${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src-11.00
MAINTAINER= ports@FreeBSD.org
COMMENT= Star field demo
@@ -20,9 +19,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_X_PREFIX= yes
do-build:
- ${CC} -I${PREFIX}/include ${CFLAGS} -c ${WRKSRC}/xwin.c -o ${WRKSRC}/xwin.o
- ${CC} -I${PREFIX}/include ${CFLAGS} -c ${WRKSRC}/main.c -o ${WRKSRC}/main.o
- ${CC} ${WRKSRC}/main.o ${WRKSRC}/xwin.o -L${PREFIX}/lib -lX11 -lm -o ${WRKSRC}/stars
+ @${CC} -I${PREFIX}/include ${CFLAGS} -c ${WRKSRC}/xwin.c -o ${WRKSRC}/xwin.o
+ @${CC} -I${PREFIX}/include ${CFLAGS} -c ${WRKSRC}/main.c -o ${WRKSRC}/main.o
+ @${CC} ${WRKSRC}/main.o ${WRKSRC}/xwin.o -L${PREFIX}/lib -lX11 -lm -o ${WRKSRC}/stars
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stars ${PREFIX}/bin/stars