aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/qlandkartegt/Makefile25
-rw-r--r--astro/qlandkartegt/distinfo3
-rw-r--r--astro/qlandkartegt/files/patch-cmake-Modules-DefineInstallationPaths.cmake11
-rw-r--r--astro/qlandkartegt/files/patch-cmakelists-out_of_source_build.cmake13
-rw-r--r--astro/qlandkartegt/pkg-descr18
-rw-r--r--astro/qlandkartegt/pkg-plist10
7 files changed, 81 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 8b1868a7bcc9..9d858636dff7 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -67,6 +67,7 @@
SUBDIR += py-pyfits
SUBDIR += pyephem
SUBDIR += pyweather
+ SUBDIR += qlandkartegt
SUBDIR += rmap
SUBDIR += roadmap
SUBDIR += roadnav
diff --git a/astro/qlandkartegt/Makefile b/astro/qlandkartegt/Makefile
new file mode 100644
index 000000000000..1f3edd40156d
--- /dev/null
+++ b/astro/qlandkartegt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: qlandkartegt
+# Date created: 1 Jun 2009
+# Whom: Mykola Dzham <freebsd@levsha.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qlandkartegt
+PORTVERSION= 0.12.0
+CATEGORIES= astro
+MASTER_SITES= SF
+
+MAINTAINER= freebsd@levsha.org.ua
+COMMENT= The ultimate outdoor aficionado's tool
+
+LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal \
+ proj.5:${PORTSDIR}/graphics/proj
+
+USE_CMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib moc_build uic_build rcc_build qmake_build opengl linguist
+
+MAN1= qlandkartegt.1
+
+.include <bsd.port.mk>
diff --git a/astro/qlandkartegt/distinfo b/astro/qlandkartegt/distinfo
new file mode 100644
index 000000000000..a9eed7a0a9da
--- /dev/null
+++ b/astro/qlandkartegt/distinfo
@@ -0,0 +1,3 @@
+MD5 (qlandkartegt-0.12.0.tar.gz) = bf9673c77289e6d6e599aa819e7fbaab
+SHA256 (qlandkartegt-0.12.0.tar.gz) = d2d0a360d8f51357f36ae2623fd913c0e4a1fa25c6fa73b90abac9887478cf34
+SIZE (qlandkartegt-0.12.0.tar.gz) = 3446336
diff --git a/astro/qlandkartegt/files/patch-cmake-Modules-DefineInstallationPaths.cmake b/astro/qlandkartegt/files/patch-cmake-Modules-DefineInstallationPaths.cmake
new file mode 100644
index 000000000000..017a0c2a7ba1
--- /dev/null
+++ b/astro/qlandkartegt/files/patch-cmake-Modules-DefineInstallationPaths.cmake
@@ -0,0 +1,11 @@
+--- cmake/Modules/DefineInstallationPaths.cmake.orig 2009-06-01 22:54:55.000000000 +0300
++++ cmake/Modules/DefineInstallationPaths.cmake 2009-06-01 22:59:02.000000000 +0300
+@@ -101,7 +101,7 @@
+ FORCE
+ )
+ SET(MAN_INSTALL_DIR
+- "${SHARE_INSTALL_PREFIX}/man"
++ "${CMAKE_INSTALL_PREFIX}/man"
+ CACHE PATH "The ${_APPLICATION_NAME} man install dir (default prefix/man)"
+ FORCE
+ )
diff --git a/astro/qlandkartegt/files/patch-cmakelists-out_of_source_build.cmake b/astro/qlandkartegt/files/patch-cmakelists-out_of_source_build.cmake
new file mode 100644
index 000000000000..4baf663def60
--- /dev/null
+++ b/astro/qlandkartegt/files/patch-cmakelists-out_of_source_build.cmake
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2009-05-06 23:24:23.000000000 +0300
++++ CMakeLists.txt 2009-05-06 23:24:46.000000000 +0300
+@@ -25,10 +25,6 @@
+ include(DefineOptions.cmake)
+ include(CPackConfig.cmake)
+
+-# disallow in-source build
+-include(MacroEnsureOutOfSourceBuild)
+-macro_ensure_out_of_source_build("${PROJECT_NAME} requires an out of source build. Please create a separate build directory and run 'cmake /path/to/${PROJECT_NAME} [options]' there.")
+-
+ # config.h generation
+ include(ConfigureChecks.cmake)
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
diff --git a/astro/qlandkartegt/pkg-descr b/astro/qlandkartegt/pkg-descr
new file mode 100644
index 000000000000..69e880ee210c
--- /dev/null
+++ b/astro/qlandkartegt/pkg-descr
@@ -0,0 +1,18 @@
+QLandkarte GT is the ultimate outdoor aficionado's tool. It supports GPS maps in
+GeoTiff format as well as Garmin's img vector map format. Additional it is the
+PC side front end to QLandkarte M, a moving map application for mobile devices.
+And it fills the gap Garmin leaves in refusing to support Linux. QLandkarte GT
+is the proof that writing portable applications for Unix, Windows and OSX is
+feasible with a minimum of overhead. No excuses!
+
+QLandkarte GT does replace the original QLandkarte with a much more flexible
+architecture. It's not limited to a map format or device. Thus if you think your
+Magellan GPS or other should be supported, join the team.
+
+Additionally it is a front end to the GDAL tools, to make georeferencing scanned
+maps feasible for the normal user. Compared to similar tools like QGis, it's
+target users are more on the consumer side than on the scientific one.
+QLandkarte GT might not let you select every possible feature of the GDAL tools,
+but it will simplify their use to the demands of most users.
+
+WWW: http://www.qlandkarte.org/
diff --git a/astro/qlandkartegt/pkg-plist b/astro/qlandkartegt/pkg-plist
new file mode 100644
index 000000000000..47c53d9aad6f
--- /dev/null
+++ b/astro/qlandkartegt/pkg-plist
@@ -0,0 +1,10 @@
+bin/qlandkartegt
+share/applications/qlandkartegt.desktop
+share/pixmaps/qlandkartegt.png
+%%DATADIR%%/translations/qlandkartegt_de_DE.qm
+%%DATADIR%%/translations/qlandkartegt_fr_FR.qm
+%%DATADIR%%/translations/qlandkartegt_it_IT.qm
+%%DATADIR%%/translations/qlandkartegt_ru_RU.qm
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%
+@dirrmtry share/applications