aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/glunarclock/Makefile7
-rw-r--r--astro/glunarclock/pkg-plist18
-rw-r--r--astro/nightfall/Makefile9
-rw-r--r--astro/nightfall/pkg-plist9
4 files changed, 21 insertions, 22 deletions
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index bf57066cbeb9..76eadbee10e0 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -3,11 +3,11 @@
# Whom: Vincent Tantardini <vinc@freebsd-fr.org>
#
# $FreeBSD$
-#
+# $MCom: ports/astro/glunarclock/Makefile,v 1.5 2007/05/19 21:35:54 marcus Exp $
PORTNAME= glunarclock
PORTVERSION= 0.32.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= astro gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +20,7 @@ LIB_DEPENDS= xklavier.11:${PORTSDIR}/x11/libxklavier
USE_XLIB= yes
USE_GNOME= gail gnomehack gnomepanel gnomeprefix gnometarget intlhack
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -30,8 +31,6 @@ PLIST_SUB= VERSION="${PORTVERSION:R}"
GCONF_SCHEMAS= glunarclock.schemas
post-patch:
- @${REINPLACE_CMD} -e \
- 's|$${prefix}/share|$${datadir}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-DGNOME_DISABLE_DEPRECATED||g'
diff --git a/astro/glunarclock/pkg-plist b/astro/glunarclock/pkg-plist
index c81b6a182c06..62be31a9ba7c 100644
--- a/astro/glunarclock/pkg-plist
+++ b/astro/glunarclock/pkg-plist
@@ -1,14 +1,14 @@
libdata/bonobo/servers/GNOME_GLunarclockApplet_Factory.server
libexec/glunarclock-applet-2
-share/gnome/glunarclock/glunarclock.glade
-share/gnome/gnome-2.0/ui/GNOME_GLunarclockApplet.xml
+share/glunarclock/glunarclock.glade
+share/gnome-2.0/ui/GNOME_GLunarclockApplet.xml
share/gnome/help/glunarclock-applet-2/C/figures/glunarclock_applet.png
share/gnome/help/glunarclock-applet-2/C/glunarclock-applet-2.xml
share/gnome/help/glunarclock-applet-2/C/legal.xml
-share/gnome/omf/glunarclock/glunarclock-applet-2-C.omf
-share/gnome/pixmaps/glunarclock-logo.png
-share/gnome/pixmaps/glunarclock/cartoonmoon_12frames.png
-share/gnome/pixmaps/glunarclock/moon_56frames.png
+share/omf/glunarclock/glunarclock-applet-2-C.omf
+share/pixmaps/glunarclock-logo.png
+share/pixmaps/glunarclock/cartoonmoon_12frames.png
+share/pixmaps/glunarclock/moon_56frames.png
share/locale/ast_ES/LC_MESSAGES/glunarclock-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/glunarclock-%%VERSION%%.mo
share/locale/br/LC_MESSAGES/glunarclock-%%VERSION%%.mo
@@ -32,12 +32,12 @@ share/locale/sr/LC_MESSAGES/glunarclock-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/glunarclock-%%VERSION%%.mo
share/locale/vi/LC_MESSAGES/glunarclock-%%VERSION%%.mo
share/locale/wa/LC_MESSAGES/glunarclock-%%VERSION%%.mo
-@dirrm share/gnome/pixmaps/glunarclock
-@dirrm share/gnome/omf/glunarclock
+@dirrm share/pixmaps/glunarclock
+@dirrm share/omf/glunarclock
@dirrm share/gnome/help/glunarclock-applet-2/C/figures
@dirrm share/gnome/help/glunarclock-applet-2/C
@dirrm share/gnome/help/glunarclock-applet-2
-@dirrm share/gnome/glunarclock
+@dirrm share/glunarclock
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/ast_ES/LC_MESSAGES
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 9ea50341905b..306dcb1ec32a 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nightfall
PORTVERSION= 1.62
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://www.la-samhna.de/nightfall/ CENKES
@@ -33,9 +34,7 @@ MAN1= nightfall.1
.if ${HAVE_GNOME:Mlibgnomeui}!=""
PKGNAMESUFFIX= -gnome
USE_GNOME+= gnomeprefix libgnomeui
-CONFIGURE_ARGS+= --with-gnomedoc-prefix=${PREFIX}/share
INSTALLS_OMF= yes
-DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
.else
CONFIGURE_ARGS+= --disable-gnome
.endif
@@ -69,12 +68,12 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS -O3|CFLAGS|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^Icon=gnome|Icon=${DATADIR}/pixmaps/gnome|g' \
+ @${REINPLACE_CMD} -e 's|^Icon=gnome|Icon=${DATADIR}/pixmaps|g' \
${WRKSRC}/nightfall.desktop
post-install:
- @${MKDIR} ${PREFIX}/share/gnome/applications
+ @${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/nightfall.desktop \
- ${PREFIX}/share/gnome/applications
+ ${PREFIX}/share/applications
.include <bsd.port.post.mk>
diff --git a/astro/nightfall/pkg-plist b/astro/nightfall/pkg-plist
index ffb6132c1807..1ede1c4a19e6 100644
--- a/astro/nightfall/pkg-plist
+++ b/astro/nightfall/pkg-plist
@@ -1,5 +1,5 @@
bin/nightfall
-share/gnome/applications/nightfall.desktop
+share/applications/nightfall.desktop
%%GNOME:%%share/gnome/help/nightfall/C/nightfall.xml
%%GNOME:%%share/gnome/help/nightfall/de/nightfall.xml
share/locale/de/LC_MESSAGES/nightfall.mo
@@ -83,9 +83,9 @@ share/locale/it/LC_MESSAGES/nightfall.mo
%%DATADIR%%/pixmaps/starp_256.jpg
%%DATADIR%%/pixmaps/stars_128.jpg
%%DATADIR%%/pixmaps/stars_256.jpg
-%%GNOME:%%share/gnome/omf/nightfall/nightfall-C.omf
-%%GNOME:%%share/gnome/omf/nightfall/nightfall-de.omf
-%%GNOME:%%@dirrm share/gnome/omf/nightfall
+%%GNOME:%%share/omf/nightfall/nightfall-C.omf
+%%GNOME:%%share/omf/nightfall/nightfall-de.omf
+%%GNOME:%%@dirrm share/omf/nightfall
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/doc/de
@dirrm %%DATADIR%%/doc/C
@@ -96,3 +96,4 @@ share/locale/it/LC_MESSAGES/nightfall.mo
%%GNOME:%%@dirrm share/gnome/help/nightfall/de
%%GNOME:%%@dirrm share/gnome/help/nightfall/C
%%GNOME:%%@dirrm share/gnome/help/nightfall
+@dirrmtry share/applications