aboutsummaryrefslogtreecommitdiffstats
path: root/audio/caps-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/caps-lv2/Makefile')
-rw-r--r--audio/caps-lv2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/caps-lv2/Makefile b/audio/caps-lv2/Makefile
index bcc71589019d..026a2d974458 100644
--- a/audio/caps-lv2/Makefile
+++ b/audio/caps-lv2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= caps-lv2
PORTVERSION= g20170626
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -11,8 +12,6 @@ COMMENT= LV2 version of the C* Audio Plugin Suite
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_armv6= fails to build: dsp/v4f.h:153:12: no matching function for call to v4f_map
-BROKEN_armv7= fails to build: dsp/v4f.h:153:12: no matching function for call to v4f_map
BROKEN_powerpc64= fails to build: cc1plus: unrecognized command line option -std=c++11
BUILD_DEPENDS= lv2>0:audio/lv2
@@ -22,6 +21,13 @@ USE_GITHUB= yes
GH_ACCOUNT= moddevices
GH_TAGNAME= 072e2fe
+# It suffers from the regression in clang-6: https://bugs.llvm.org/show_bug.cgi?id=36916
+LLVM_VER= 50
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CPP= clang-cpp${LLVM_VER}
+CC= clang${LLVM_VER}
+CXX= clang++${LLVM_VER}
+
post-patch:
@${REINPLACE_CMD} -e "s|__APPLE__|__FreeBSD__|" \
${WRKSRC}/dsp/v4f_IIR2.h