aboutsummaryrefslogtreecommitdiffstats
path: root/audio/deadbeef
diff options
context:
space:
mode:
Diffstat (limited to 'audio/deadbeef')
-rw-r--r--audio/deadbeef/Makefile16
-rw-r--r--audio/deadbeef/distinfo6
-rw-r--r--audio/deadbeef/pkg-plist12
3 files changed, 23 insertions, 11 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index a16b26bddf8c..5a4806ff8634 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -6,26 +6,26 @@
#
PORTNAME= deadbeef
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/
-#DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= g.veniamin@googlemail.com
COMMENT= DeaDBeeF is an audio player
LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
- mad.2:${PORTSDIR}/audio/libmad
+ mad.2:${PORTSDIR}/audio/libmad \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_ICONV= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I../dumb/dumb-kode54/include -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lexecinfo"
CONFIGURE_ARGS= --disable-alsa --disable-nullout
WANT_GNOME= yes
INSTALLS_ICONS= yes
-MAKE_JOBS_SAGE= yes
+MAKE_JOBS_SAFE= yes
OPTIONS= PULSE "PulseAudio output plugin (unsupported)" off\
GUI "standard GTK2 user interface plugin" on\
@@ -90,7 +90,7 @@ PLIST_SUB+= ART="@comment "
PLIST_SUB+= ART=""
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
.else
-BROKEN= Please enable VFS plugin
+BROKEN= VFS plugin required for album art loader, please rerun 'make config' and either disable ART or enable VFS
.endif
.endif
@@ -150,7 +150,7 @@ PLIST_SUB+= FFMPEG="@comment "
.else
PLIST_SUB+= FFMPEG=""
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- avformat:${PORTSDIR}/multimedia/ffmpeg \
+ avformat.1:${PORTSDIR}/multimedia/ffmpeg \
avutil.1:${PORTSDIR}/multimedia/ffmpeg
.endif
diff --git a/audio/deadbeef/distinfo b/audio/deadbeef/distinfo
index 7f33731640da..537b47be75a0 100644
--- a/audio/deadbeef/distinfo
+++ b/audio/deadbeef/distinfo
@@ -1,3 +1,3 @@
-MD5 (deadbeef-0.4.0.tar.bz2) = 4a8afe84288e2ca99f5b3dd584d11553
-SHA256 (deadbeef-0.4.0.tar.bz2) = 96febed8f52ec581ab902b1282a12e467123a2784395524d409c60f98ce53087
-SIZE (deadbeef-0.4.0.tar.bz2) = 1202706
+MD5 (deadbeef-0.4.1.tar.bz2) = 69383c6490461751c2ec6281158a8624
+SHA256 (deadbeef-0.4.1.tar.bz2) = f80a898e1f8b803ddf8e428bae89d0e682433806aa2b06c2f7c8c53e07d852fe
+SIZE (deadbeef-0.4.1.tar.bz2) = 1205706
diff --git a/audio/deadbeef/pkg-plist b/audio/deadbeef/pkg-plist
index 0135e48ae94e..c7f5b113d992 100644
--- a/audio/deadbeef/pkg-plist
+++ b/audio/deadbeef/pkg-plist
@@ -36,6 +36,10 @@ lib/deadbeef/oss.a
lib/deadbeef/oss.la
lib/deadbeef/oss.so
lib/deadbeef/oss.so.0
+%%PULSE%%lib/deadbeef/pulse.a
+%%PULSE%%lib/deadbeef/pulse.la
+%%PULSE%%lib/deadbeef/pulse.so
+%%PULSE%%lib/deadbeef/pulse.so.0
%%SNDFILE%%lib/deadbeef/sndfile.a
%%SNDFILE%%lib/deadbeef/sndfile.la
%%SNDFILE%%lib/deadbeef/sndfile.so
@@ -103,6 +107,14 @@ share/applications/deadbeef.desktop
share/icons/hicolor/16x16/apps/deadbeef.png
share/icons/hicolor/32x32/apps/deadbeef.png
share/icons/hicolor/48x48/apps/deadbeef.png
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
%%DATADIR%%/pixmaps/noartwork.jpg
@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/pixmaps