aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3chew/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3chew/Makefile')
-rw-r--r--audio/mp3chew/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/mp3chew/Makefile b/audio/mp3chew/Makefile
new file mode 100644
index 000000000000..a109b8683a14
--- /dev/null
+++ b/audio/mp3chew/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mp3chew
+# Date created: 10 March 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3chew
+PORTVERSION= 0.51.0
+CATEGORIES= audio
+MASTER_SITES= http://owl.yi.org/mp3chew/download/tar/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+ALL_TARGET= ${PORTNAME}
+
+DOCFILES= CHANGELOG INSTALL README TODO
+
+post-patch:
+ @${PERL} -pi.fbsd -e 's, _to, to,g' ${WRKSRC}/CMp3Filter.cc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mp3chew ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+.for D in ${DOCFILES}
+ ${MKDIR} ${PREFIX}/share/doc/mp3chew
+ ${INSTALL_DATA} ${WRKSRC}/docs/$D ${PREFIX}/share/doc/mp3chew
+.endfor
+.endif
+
+.include <bsd.port.mk>