aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ncmpcpp
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ncmpcpp')
-rw-r--r--audio/ncmpcpp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index e2b753f62e1e..7c9998d06003 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -30,6 +30,9 @@ OPTIONS= CURL "Enable fetching lyrics from the Internet" on \
.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
+.else
+# no need to use ncurses-config if we use ncurses from the base system
+CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
.endif
PLIST_FILES= bin/ncmpcpp \
@@ -46,7 +49,7 @@ CONFIGURE_ARGS+= --with-curl
CONFIGURE_ARGS+= --with-curl=no
.endif
-.if !defined(WITH_TAGLIB)
+.if !defined(WITHOUT_TAGLIB)
LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
CONFIGURE_ARGS+= --with-taglib
.else