aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile2
-rw-r--r--audio/grip/Makefile67
-rw-r--r--audio/grip/distinfo3
-rw-r--r--audio/grip/files/patch-src_cdplay.c10
-rw-r--r--audio/grip/files/patch-src_grip.c28
-rw-r--r--audio/grip/files/patch-src_gripcfg.c25
-rw-r--r--audio/grip/files/patch-src_main.c11
-rw-r--r--audio/grip/files/patch-src_tray.c10
-rw-r--r--audio/grip/pkg-descr8
-rw-r--r--audio/grip/pkg-plist84
-rw-r--r--audio/jack-rack/Makefile33
-rw-r--r--audio/jack-rack/distinfo2
-rw-r--r--audio/jack-rack/files/patch-fix_with_gtk-2.1216
-rw-r--r--audio/jack-rack/files/patch-src_plugin__slot__callbacks.c18
-rw-r--r--audio/jack-rack/pkg-descr5
-rw-r--r--audio/jack-rack/pkg-plist16
16 files changed, 0 insertions, 338 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 3cb02352f193..7837961a6544 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -249,7 +249,6 @@
SUBDIR += gqradio
SUBDIR += gradio
SUBDIR += gramofile
- SUBDIR += grip
SUBDIR += gsm
SUBDIR += gsound
SUBDIR += gstreamer-plugins-a52dec
@@ -356,7 +355,6 @@
SUBDIR += ir-lv2
SUBDIR += jack
SUBDIR += jack-keyboard
- SUBDIR += jack-rack
SUBDIR += jack-smf-utils
SUBDIR += jack_ghero
SUBDIR += jack_mixer
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
deleted file mode 100644
index 1ab0211d7302..000000000000
--- a/audio/grip/Makefile
+++ /dev/null
@@ -1,67 +0,0 @@
-# Created by: kbyanc@posi.net
-# $FreeBSD$
-
-PORTNAME= grip
-PORTVERSION= 3.7.0
-CATEGORIES= audio
-MASTER_SITES= SF/grip/${PORTVERSION}
-
-MAINTAINER= multimedia@FreeBSD.org
-COMMENT= GTK front-end to external cd rippers and audio encoders
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-DEPRECATED= GNOME 2 application
-EXPIRATION_DATE= 2018-12-10
-
-LIB_DEPENDS= libcurl.so:ftp/curl \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libid3.so:audio/id3lib \
- libpopt.so:devel/popt
-
-USES= gmake libtool localbase pathfix pkgconfig
-USE_XORG= ice sm x11 xext
-USE_GNOME= cairo gdkpixbuf2 gnomeprefix libgnomeui vte
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-werror
-INSTALLS_ICONS= yes
-
-OPTIONS_DEFINE= CDPARANOIA CDDA2WAV LAME VORBIS FAAC FLAC NLS
-OPTIONS_DEFAULT= CDPARANOIA VORBIS
-
-.if !defined(PACKAGE_BUILDING)
-OPTIONS_DEFAULT+= LAME
-.endif
-
-OPTIONS_SUB= yes
-
-CDPARANOIA_LIB_DEPENDS= libcdda_paranoia.so:audio/cdparanoia
-CDPARANOIA_CONFIGURE_ENABLE= cdpar
-CDDA2WAV_RUN_DEPENDS= cdda2wav:sysutils/cdrtools
-FAAC_RUN_DEPENDS= faac:audio/faac
-FLAC_RUN_DEPENDS= flac:audio/flac
-LAME_RUN_DEPENDS= lame:audio/lame
-VORBIS_RUN_DEPENDS= ogg123:audio/vorbis-tools
-NLS_USES= gettext
-
-.if defined(WITH_CDROM_DEVICE)
-DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
-.else
-DEFAULT_CDROM_DEVICE=/dev/cd0
-.endif
-
-pre-everything::
-.if !defined(WITH_CDROM_DEVICE)
- @${ECHO_MSG} "===> The default CDROM device is ${DEFAULT_CDROM_DEVICE}"
- @${ECHO_MSG} "===> Define WITH_CDROM_DEVICE if you want to change the default"
- @${ECHO_MSG} "===> For example, 'make WITH_CDROM_DEVICE=\"/dev/somedevice\"'"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
- ${WRKSRC}/src/grip.c
-
-.include <bsd.port.mk>
diff --git a/audio/grip/distinfo b/audio/grip/distinfo
deleted file mode 100644
index f0a5f277f98b..000000000000
--- a/audio/grip/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1523001507
-SHA256 (grip-3.7.0.tar.gz) = 9aaef780f4af74a710c82ce445226a76870101a7f7de0c3fb28ee9e4fd916087
-SIZE (grip-3.7.0.tar.gz) = 961006
diff --git a/audio/grip/files/patch-src_cdplay.c b/audio/grip/files/patch-src_cdplay.c
deleted file mode 100644
index 5ec3504a40f0..000000000000
--- a/audio/grip/files/patch-src_cdplay.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/cdplay.c.orig 2017-10-29 05:14:46 UTC
-+++ src/cdplay.c
-@@ -20,6 +20,7 @@
- * USA
- */
-
-+#include <sys/wait.h>
- #include "cdplay.h"
- #include "grip.h"
- #include "config.h"
diff --git a/audio/grip/files/patch-src_grip.c b/audio/grip/files/patch-src_grip.c
deleted file mode 100644
index 8db353e42ced..000000000000
--- a/audio/grip/files/patch-src_grip.c
+++ /dev/null
@@ -1,28 +0,0 @@
-Since it is the default, the oggenc encoder was moved to the beginning of the
-encoder_defaults list in src/gripcfg.c. We set selected_encoder=0 here to
-reflect that change. This also prevents the offset from getting screwed up
-if encoders are added or removed from the list.
-
-Fix the oggenc arguments. Input file "%w" should be at the end.
-
---- src/grip.c.orig 2018-01-31 15:06:36 UTC
-+++ src/grip.c
-@@ -29,6 +29,7 @@
- #include <gdk/gdkx.h>
- #include <X11/Xlib.h>
- #include <time.h>
-+#include <sys/wait.h>
- #include "grip.h"
- #include <libgnomeui/gnome-window-icon.h>
- #include "discdb.h"
-@@ -897,8 +898,8 @@ static void DoLoadConfig(GripInfo *ginfo)
- ginfo->stop_between_tracks=FALSE;
- *ginfo->wav_filter_cmd='\0';
- *ginfo->disc_filter_cmd='\0';
-- ginfo->selected_encoder=6;
-- strcpy(ginfo->mp3cmdline,"-o %m -a %a -l %d -t %n -b %b %w -N %t -G %G -d %y");
-+ ginfo->selected_encoder=0;
-+ strcpy(ginfo->mp3cmdline,"-o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w");
- FindExeInPath("oggenc", ginfo->mp3exename, sizeof(ginfo->mp3exename));
- strcpy(ginfo->mp3fileformat,"~/ogg/%A/%d/%t_%n.%x");
- strcpy(ginfo->mp3fileformat_multi,"~/ogg/%A/%d/%t_%a_%n.%x");
diff --git a/audio/grip/files/patch-src_gripcfg.c b/audio/grip/files/patch-src_gripcfg.c
deleted file mode 100644
index 3a1a235cc0a6..000000000000
--- a/audio/grip/files/patch-src_gripcfg.c
+++ /dev/null
@@ -1,25 +0,0 @@
-Adjust the encoder list to contain only those we have ports for.
-Move oggenc to the beginning of the list since it is the default and to
-prevent future offset errors if other encoders are added or removed.
-
---- src/gripcfg.c.orig 2018-04-06 23:41:51 UTC
-+++ src/gripcfg.c
-@@ -47,16 +47,9 @@ static Ripper ripper_defaults[]={
- {"",""}
- };
-
--static MP3Encoder encoder_defaults[]={{"bladeenc","-%b -QUIT %w %m","mp3"},
-+static MP3Encoder encoder_defaults[]={{"oggenc","-o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w","ogg"},
- {"lame","-h --add-id3v2 --tt \"%n\" --ta \"%a\" --tl \"%d\" --ty \"%y\" --tn \"%t\" --tg \"%G\" -b %b %w %m","mp3"},
-- {"l3enc","-br %b %w %m","mp3"},
-- {"xingmp3enc","-B %b -Q %w","mp3"},
-- {"mp3encode","-p 2 -l 3 -b %b %w %m",
-- "mp3"},
-- {"gogo","-b %b %w %m","mp3"},
-- {"oggenc",
-- "-o %m -a %a -l %d -t %n -b %b -N %t -G %G -d %y %w",
-- "ogg"},
-+ {"faac","--no-midside -w -q 100 --artist %a --album %d --track %t --title %n --year %y --genre %g -b %b %w -o %m", "m4a"},
- {"flac","--best --replay-gain -T title=\"%n\" -T artist=\"%a\" -T album=\"%d\" -T date=\"%y\" -T tracknumber=\"%t\" -T genre=\"%G\" -o %m %w","flac"},
- {"other","",""},
- {"",""}
diff --git a/audio/grip/files/patch-src_main.c b/audio/grip/files/patch-src_main.c
deleted file mode 100644
index b509371b68e8..000000000000
--- a/audio/grip/files/patch-src_main.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/main.c.orig 2005-06-25 18:00:55 UTC
-+++ src/main.c
-@@ -164,7 +164,7 @@ int Cmain(int argc, char* argv[])
- GNOME_PARAM_POPT_TABLE,options,
- GNOME_PROGRAM_STANDARD_PROPERTIES,NULL);
-
-- bind_textdomain_codeset(GETTEXT_PACKAGE, "UTF8");
-+ bind_textdomain_codeset(GETTEXT_PACKAGE, "UTF-8");
- setenv("CHARSET","UTF-8",1);
-
- /* Session Management */
diff --git a/audio/grip/files/patch-src_tray.c b/audio/grip/files/patch-src_tray.c
deleted file mode 100644
index 85aaacc8a757..000000000000
--- a/audio/grip/files/patch-src_tray.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/tray.c.orig 2017-07-31 21:04:11 UTC
-+++ src/tray.c
-@@ -21,6 +21,7 @@
- */
-
- #include "cdplay.h"
-+#include "common.h"
- #include "tray.h"
- #include "rip.h"
- #include "uihelper.h"
diff --git a/audio/grip/pkg-descr b/audio/grip/pkg-descr
deleted file mode 100644
index 34509efca804..000000000000
--- a/audio/grip/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Grip is a front-end to external cd audio rippers (such as dagrab or
-cdda2wav). It also provides an automated frontend for MP3 encoders, letting
-you take a disc and transform it easily straight into MP3s. The CDDB
-protocol is supported for retrieving track information from disc database
-servers. Grip works with DigitalDJ to provide a unified "computerized"
-version of your music collection.
-
-WWW: https://sourceforge.net/projects/grip/
diff --git a/audio/grip/pkg-plist b/audio/grip/pkg-plist
deleted file mode 100644
index 53738c2e9bd1..000000000000
--- a/audio/grip/pkg-plist
+++ /dev/null
@@ -1,84 +0,0 @@
-bin/grip
-man/man1/grip.1.gz
-share/applications/grip.desktop
-share/apps/solid/actions/grip-audiocd.desktop
-share/gnome/help/grip/C/cdconfig.png
-share/gnome/help/grip/C/cdplayer.png
-share/gnome/help/grip/C/cdplayersmall.png
-share/gnome/help/grip/C/cdscan.png
-share/gnome/help/grip/C/discdb.png
-share/gnome/help/grip/C/discdbconfig.png
-share/gnome/help/grip/C/editing.png
-share/gnome/help/grip/C/eject.png
-share/gnome/help/grip/C/encprog.png
-share/gnome/help/grip/C/ffwd.png
-share/gnome/help/grip/C/grip-logo.png
-share/gnome/help/grip/C/grip.xml
-share/gnome/help/grip/C/id3config.png
-share/gnome/help/grip/C/minmax.png
-share/gnome/help/grip/C/miscconfig.png
-share/gnome/help/grip/C/modeinterface.png
-share/gnome/help/grip/C/mp3config.png
-share/gnome/help/grip/C/mp3config2.png
-share/gnome/help/grip/C/multiartist.png
-share/gnome/help/grip/C/nexttrk.png
-share/gnome/help/grip/C/playloop.png
-share/gnome/help/grip/C/playnormal.png
-share/gnome/help/grip/C/playonce.png
-share/gnome/help/grip/C/playpause.png
-share/gnome/help/grip/C/playplaylist.png
-share/gnome/help/grip/C/playrandom.png
-share/gnome/help/grip/C/prevtrk.png
-share/gnome/help/grip/C/progtrack.png
-share/gnome/help/grip/C/proxyconfig.png
-share/gnome/help/grip/C/quit.png
-share/gnome/help/grip/C/rewind.png
-share/gnome/help/grip/C/ripconfig.png
-share/gnome/help/grip/C/ripconfig2.png
-share/gnome/help/grip/C/ripconfig3.png
-share/gnome/help/grip/C/ripping.png
-share/gnome/help/grip/C/ripprog.png
-share/gnome/help/grip/C/ripsmall.png
-share/gnome/help/grip/C/smile1.png
-share/gnome/help/grip/C/smile2.png
-share/gnome/help/grip/C/smile3.png
-share/gnome/help/grip/C/smile4.png
-share/gnome/help/grip/C/smile5.png
-share/gnome/help/grip/C/smile6.png
-share/gnome/help/grip/C/smile7.png
-share/gnome/help/grip/C/smile8.png
-share/gnome/help/grip/C/stop.png
-share/gnome/help/grip/C/trkedit.png
-share/gnome/help/grip/C/volume.png
-share/icons/hicolor/16x16/apps/grip.png
-share/icons/hicolor/22x22/apps/grip.png
-share/icons/hicolor/24x24/apps/grip.png
-share/icons/hicolor/32x32/apps/grip.png
-share/icons/hicolor/48x48/apps/grip.png
-share/icons/hicolor/64x64/apps/grip.png
-share/icons/hicolor/72x72/apps/grip.png
-share/icons/hicolor/scalable/apps/grip.svg
-%%NLS%%share/locale/be/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/de/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/es/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/fur/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/it/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/zh_HK/LC_MESSAGES/grip.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/grip.mo
-share/pixmaps/grip.png
-share/pixmaps/griptray.png
diff --git a/audio/jack-rack/Makefile b/audio/jack-rack/Makefile
deleted file mode 100644
index 53482b7923c9..000000000000
--- a/audio/jack-rack/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# Created by: Jean-Yves Lefort <jylefort@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= jack-rack
-PORTVERSION= 1.4.7
-PORTREVISION= 9
-CATEGORIES= audio
-MASTER_SITES= SF
-
-MAINTAINER= multimedia@FreeBSD.org
-COMMENT= LADSPA effects rack for the JACK audio server
-
-DEPRECATED= GNOME 2 application
-EXPIRATION_DATE= 2018-12-10
-
-BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
-LIB_DEPENDS= libjack.so:audio/jack \
- liblrdf.so:textproc/liblrdf
-RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
-
-USE_GNOME= libgnomeui libxml2
-USES= gettext shebangfix pkgconfig python tar:bzip2
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm
-CONFIGURE_ARGS= --disable-ladcca --disable-lash --disable-aseq
-SHEBANG_FILES= ecarack
-
-post-patch:
- @${REINPLACE_CMD} -e '/^jr_desktop_install/ s|/usr/share|${PREFIX}/share|' \
- ${WRKSRC}/configure
-
-.include <bsd.port.mk>
diff --git a/audio/jack-rack/distinfo b/audio/jack-rack/distinfo
deleted file mode 100644
index 3cd1c7d9509e..000000000000
--- a/audio/jack-rack/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (jack-rack-1.4.7.tar.bz2) = 85808713edf7ad8da5f65fa35ee8a4084483213692291dd9654fb1f8525fb1d2
-SIZE (jack-rack-1.4.7.tar.bz2) = 269478
diff --git a/audio/jack-rack/files/patch-fix_with_gtk-2.12 b/audio/jack-rack/files/patch-fix_with_gtk-2.12
deleted file mode 100644
index 2638a859f318..000000000000
--- a/audio/jack-rack/files/patch-fix_with_gtk-2.12
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/Makefile.in.orig 2007-11-26 22:24:06 UTC
-+++ src/Makefile.in
-@@ -261,12 +261,7 @@ jack_rack_CFLAGS = \
- $(XML_CFLAGS) \
- -DPKGDATADIR=\"$(pkgdatadir)\" \
- -DPIXMAPDIR=\"$(pixmapdir)\" \
-- -DDTDDIR=\"$(dtddir)\" \
-- -DG_DISABLE_DEPRECATED=1 \
-- -DGTK_DISABLE_DEPRECATED=1 \
-- -DGDK_DISABLE_DEPRECATED=1 \
-- -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
-- -DGNOME_DISABLE_DEPRECATED=1
-+ -DDTDDIR=\"$(dtddir)\"
-
- jack_rack_LDFLAGS = \
- $(JACK_LIBS) \
diff --git a/audio/jack-rack/files/patch-src_plugin__slot__callbacks.c b/audio/jack-rack/files/patch-src_plugin__slot__callbacks.c
deleted file mode 100644
index f88164d0a52c..000000000000
--- a/audio/jack-rack/files/patch-src_plugin__slot__callbacks.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/plugin_slot_callbacks.c.orig 2007-11-18 13:13:49 UTC
-+++ src/plugin_slot_callbacks.c
-@@ -109,6 +109,7 @@ slot_ablise_cb (GtkWidget * button, GdkE
-
- ui = plugin_slot->jack_rack->ui;
-
-+#ifdef HAVE_ALSA
- g_object_set_data (G_OBJECT (ui->midi_menu_item),
- "jack-rack-ctrl-type",
- GINT_TO_POINTER(2/*PLUGIN_ENABLE_CONTROL*/));
-@@ -117,6 +118,7 @@ slot_ablise_cb (GtkWidget * button, GdkE
- plugin_slot);
- gtk_menu_popup (GTK_MENU (ui->midi_menu), NULL, NULL, NULL, NULL, event->button, event->time);
-
-+#endif
- return TRUE;
- }
- }
diff --git a/audio/jack-rack/pkg-descr b/audio/jack-rack/pkg-descr
deleted file mode 100644
index 319de7f49d06..000000000000
--- a/audio/jack-rack/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-JACK Rack is an effects "rack" for the JACK low latency audio API. The rack
-can be filled with LADSPA effects plugins. It's phat; it turns your computer
-into an effects box.
-
-WWW: http://jack-rack.sourceforge.net/
diff --git a/audio/jack-rack/pkg-plist b/audio/jack-rack/pkg-plist
deleted file mode 100644
index 9d6c6dc85c50..000000000000
--- a/audio/jack-rack/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-bin/jack-rack
-bin/ecarack
-share/applications/jack-rack.desktop
-share/dtds/jack_rack_1.0.dtd
-share/dtds/jack_rack_1.1.dtd
-share/dtds/jack_rack_1.2.dtd
-share/dtds/jack_rack_1.3.dtd
-%%DATADIR%%/gnome-mixer-small.png
-%%DATADIR%%/jack-rack-logo.png
-%%DATADIR%%/jr-cross.png
-%%DATADIR%%/jr-down-arrow.png
-%%DATADIR%%/jr-up-arrow.png
-share/locale/fr/LC_MESSAGES/jack-rack.mo
-share/locale/de/LC_MESSAGES/jack-rack.mo
-share/locale/ru/LC_MESSAGES/jack-rack.mo
-share/pixmaps/jack-rack-icon.png