aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3butler/Makefile30
-rw-r--r--audio/mp3butler/distinfo1
-rw-r--r--audio/mp3butler/files/patch-aa8
-rw-r--r--audio/mp3butler/pkg-comment1
-rw-r--r--audio/mp3butler/pkg-descr11
-rw-r--r--audio/mp3butler/pkg-plist7
7 files changed, 59 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 38925c83f2e9..3b3a4ca4740a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -105,6 +105,7 @@
SUBDIR += mixer.app
SUBDIR += mp3_check
SUBDIR += mp3blaster
+ SUBDIR += mp3butler
SUBDIR += mp3check
SUBDIR += mp3chew
SUBDIR += mp3encode
diff --git a/audio/mp3butler/Makefile b/audio/mp3butler/Makefile
new file mode 100644
index 000000000000..0a295429a78e
--- /dev/null
+++ b/audio/mp3butler/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mp3butler
+# Date created: 30 April 2001
+# Whom: Christopher Preston <rbg@gayteenresource.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3butler
+PORTVERSION= 1.0.1
+CATEGORIES= audio
+MASTER_SITES= http://projects.babblica.net/butler/versions/
+
+MAINTAINER= rbg@gayteenresource.org
+
+MAN1= mp3butler.1
+
+do-build:
+ (cd ${WRKSRC} && ${SH} ./mkdocs)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mp3butler.pl ${PREFIX}/bin/mp3butler
+ ${INSTALL_MAN} ${WRKSRC}/mp3butler.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+.for I in COPYING ChangeLog INSTALL RANT README
+ ${MKDIR} ${PREFIX}/share/doc/mp3butler
+ ${INSTALL_DATA} ${WRKSRC}/$I ${PREFIX}/share/doc/mp3butler
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/mp3butler/distinfo b/audio/mp3butler/distinfo
new file mode 100644
index 000000000000..6c52f7e80dd0
--- /dev/null
+++ b/audio/mp3butler/distinfo
@@ -0,0 +1 @@
+MD5 (mp3butler-1.0.1.tar.gz) = 188f274feecda7f7150a0a25c5ea8be1
diff --git a/audio/mp3butler/files/patch-aa b/audio/mp3butler/files/patch-aa
new file mode 100644
index 000000000000..94f0d0e7f2ab
--- /dev/null
+++ b/audio/mp3butler/files/patch-aa
@@ -0,0 +1,8 @@
+--- mkdocs.orig Mon Apr 30 15:10:33 2001
++++ mkdocs Mon Apr 30 15:10:39 2001
+@@ -4,5 +4,4 @@
+ pod2text mp3butler.pl > mp3butler-manpage.txt
+ echo creating mp3butler manual page: mp3butler.1.gz
+ pod2man mp3butler.pl --center='BabblicaSoft Documentation' > mp3butler.1
+-gzip mp3butler.1
+
diff --git a/audio/mp3butler/pkg-comment b/audio/mp3butler/pkg-comment
new file mode 100644
index 000000000000..049b52b55e9c
--- /dev/null
+++ b/audio/mp3butler/pkg-comment
@@ -0,0 +1 @@
+A program for renaming mp3 files
diff --git a/audio/mp3butler/pkg-descr b/audio/mp3butler/pkg-descr
new file mode 100644
index 000000000000..7191c58b9d7e
--- /dev/null
+++ b/audio/mp3butler/pkg-descr
@@ -0,0 +1,11 @@
+Mp3butler is a program written in perl for renaming your mp3's.
+
+ o It will remove all characters that require shell escapes from filenames
+ o It will remove capitalization from filenames
+ o It can create ID3 tags using the filename
+ o It can reorganize your mp3's into an organizational hierarchy
+
+WWW: http://projects.babblica.net/butler/
+
+- Christopher Preston
+rbg@gayteenresource.org
diff --git a/audio/mp3butler/pkg-plist b/audio/mp3butler/pkg-plist
new file mode 100644
index 000000000000..a80bf3ac3f98
--- /dev/null
+++ b/audio/mp3butler/pkg-plist
@@ -0,0 +1,7 @@
+bin/mp3butler
+%%PORTDOCS%%share/doc/mp3butler/COPYING
+%%PORTDOCS%%share/doc/mp3butler/ChangeLog
+%%PORTDOCS%%share/doc/mp3butler/INSTALL
+%%PORTDOCS%%share/doc/mp3butler/RANT
+%%PORTDOCS%%share/doc/mp3butler/README
+%%PORTDOCS%%@dirrm share/doc/mp3butler