aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mpz/Makefile30
-rw-r--r--audio/mpz/distinfo3
-rw-r--r--audio/mpz/files/patch-app_app.pro35
-rw-r--r--audio/mpz/files/patch-mpz.pro22
-rw-r--r--audio/mpz/pkg-descr18
6 files changed, 109 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index c5068b9bc80e..1d1de559885e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -536,6 +536,7 @@
SUBDIR += mpg321
SUBDIR += mpiosh
SUBDIR += mps
+ SUBDIR += mpz
SUBDIR += mumble
SUBDIR += murmur
SUBDIR += muse-sequencer
diff --git a/audio/mpz/Makefile b/audio/mpz/Makefile
new file mode 100644
index 000000000000..410ebf260d90
--- /dev/null
+++ b/audio/mpz/Makefile
@@ -0,0 +1,30 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mpz
+PORTVERSION= 1.0.1
+CATEGORIES= audio
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Music player for big local collections
+
+LICENSE= GPLv3+
+
+LIB_DEPENDS= libtag.so:audio/taglib \
+ libyaml-cpp.so:devel/yaml-cpp
+
+USE_GITHUB= yes
+GH_ACCOUNT= olegantonyan
+
+USES= compiler:c++11-lang qmake qt:5
+USE_GSTREAMER1= flac libav mpg123 ogg opus vorbis
+USE_QT= buildtools_build concurrent core dbus gui multimedia \
+ network widgets x11extras
+
+PLIST_FILES= bin/mpz share/applications/mpz.desktop \
+ share/icons/hicolor/512x512/apps/mpz.png
+
+post-extract:
+ @${RM} -r ${WRKSRC}/libs/taglib ${WRKSRC}/libs/yaml-cpp
+
+.include <bsd.port.mk>
diff --git a/audio/mpz/distinfo b/audio/mpz/distinfo
new file mode 100644
index 000000000000..d72d648a3c3a
--- /dev/null
+++ b/audio/mpz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1602178609
+SHA256 (olegantonyan-mpz-1.0.1_GH0.tar.gz) = fef17411123a0c5eed3ec8e62d56aa96978ef316954717c0c6086cdb129bbf38
+SIZE (olegantonyan-mpz-1.0.1_GH0.tar.gz) = 2854539
diff --git a/audio/mpz/files/patch-app_app.pro b/audio/mpz/files/patch-app_app.pro
new file mode 100644
index 000000000000..d5aaa0fa6222
--- /dev/null
+++ b/audio/mpz/files/patch-app_app.pro
@@ -0,0 +1,35 @@
+--- app/app.pro.orig 2020-10-08 17:36:49 UTC
++++ app/app.pro
+@@ -7,8 +7,6 @@ CONFIG += c++11
+
+ TARGET = mpz
+
+-DEFINES += TAGLIB_STATIC
+-
+ win32: {
+ CONFIG -= debug_and_release
+ #CONFIG += static
+@@ -134,14 +132,14 @@ FORMS += \
+
+ # Libraries
+ INCLUDEPATH += \
+- ../libs/taglib/taglib-1.11.1/taglib \
++ ${LOCALBASE}/include/taglib \
+ ../libs/taglib/taglib-1.11.1/taglib/toolkit \
+ ../libs/yaml-cpp/yaml-cpp-0.6.3/include \
+ ../libs/qtwaitingspinner \
+ ../libs/qhotkey/QHotkey-1.4.1
+
+ LIBS += \
+- -L../libs/taglib -ltaglib \
++ -L${LOCALBASE}/lib -ltag \
+ -L../libs/yaml-cpp -lyaml-cpp \
+ -L../libs/qtwaitingspinner -lqtwaitingspinner \
+ -L../libs/qhotkey -lqhotkey
+@@ -165,5 +163,5 @@ RESOURCES += \
+ resources/resources.qrc
+
+ # make install
+-target.path = /usr/bin/
++target.path = $$PREFIX/bin/
+ INSTALLS += target
diff --git a/audio/mpz/files/patch-mpz.pro b/audio/mpz/files/patch-mpz.pro
new file mode 100644
index 000000000000..77e7593ad947
--- /dev/null
+++ b/audio/mpz/files/patch-mpz.pro
@@ -0,0 +1,22 @@
+--- mpz.pro.orig 2020-10-08 17:36:49 UTC
++++ mpz.pro
+@@ -2,17 +2,15 @@ TEMPLATE = subdirs
+ CONFIG += ordered
+
+ SUBDIRS = \
+- libs/taglib \
+- libs/yaml-cpp \
+ libs/qtwaitingspinner \
+ libs/qhotkey \
+ app
+
+ # make install
+-desktop.path = /usr/share/applications/
++desktop.path = $$PREFIX/share/applications/
+ desktop.files += mpz.desktop
+
+-icon.path = /usr/share/icons/hicolor/512x512/apps/
++icon.path = $$PREFIX/share/icons/hicolor/512x512/apps/
+ icon.files += app/resources/icons/mpz.png
+
+ INSTALLS += desktop icon
diff --git a/audio/mpz/pkg-descr b/audio/mpz/pkg-descr
new file mode 100644
index 000000000000..31ab559a7b14
--- /dev/null
+++ b/audio/mpz/pkg-descr
@@ -0,0 +1,18 @@
+Music player for big local collections.
+
+Features 3 columns UI: directory tree (aka library), playlists and tracks
+from selected playlist. Middle-click on folder or track in the directory
+view and it will become a playlist an its content will be loaded into
+tracks view. Create multiple playlists from folders in your library and
+switch between them quickly. Similar to "Album list" in Foobar2000.
+
+Built with C++ and Qt framework -- lightweight and fast. Open Source and
+cross-platform. Uses audio codecs installed on your system (GStreamer
+though QtMultimedia). Follows you desktop theme.
+
+Supports radio streams in .pls and .m3u playlsts. Supports CUE. Has a
+playback log which is helpful for radio stream -- never miss a track you
+liked. Supports MPRIS -- ability to control playback remotely, for
+example, via KDE Connect.
+
+WWW: https://olegantonyan.github.io/mpz/