aboutsummaryrefslogtreecommitdiffstats
path: root/biology/fasttree/files
diff options
context:
space:
mode:
Diffstat (limited to 'biology/fasttree/files')
-rw-r--r--biology/fasttree/files/Makefile25
-rw-r--r--biology/fasttree/files/patch-FastTree-2.1.10.c11
2 files changed, 36 insertions, 0 deletions
diff --git a/biology/fasttree/files/Makefile b/biology/fasttree/files/Makefile
new file mode 100644
index 000000000000..ada070cda53b
--- /dev/null
+++ b/biology/fasttree/files/Makefile
@@ -0,0 +1,25 @@
+
+BIN = FastTree
+SRC = FastTree*.c
+CC ?= gcc
+CFLAGS ?= -O3
+CFLAGS += -DOPENMP -fopenmp -finline-functions -funroll-loops
+
+MKDIR ?= mkdir
+INSTALL ?= install
+PREFIX ?= /usr/local
+DESTDIR ?= .
+
+.PHONY: all install clean
+
+all: ${BIN}
+
+${BIN}: ${SRC} Makefile
+ ${CC} ${CFLAGS} ${SRC} -o ${BIN} -lm
+
+install: ${BIN}
+ ${MKDIR} -p ${DESTDIR}${PREFIX}/bin
+ ${INSTALL} -s -c ${BIN} ${DESTDIR}${PREFIX}/bin
+
+clean:
+ ${RM} -f ${BIN}
diff --git a/biology/fasttree/files/patch-FastTree-2.1.10.c b/biology/fasttree/files/patch-FastTree-2.1.10.c
new file mode 100644
index 000000000000..36dd31ceb877
--- /dev/null
+++ b/biology/fasttree/files/patch-FastTree-2.1.10.c
@@ -0,0 +1,11 @@
+--- FastTree-2.1.10.c.orig 2017-12-04 15:09:11 UTC
++++ FastTree-2.1.10.c
+@@ -8759,7 +8759,7 @@ double pnorm(double x)
+
+ void *mymalloc(size_t sz) {
+ if (sz == 0) return(NULL);
+- void *new = malloc(sz);
++ void *new = aligned_alloc(16, sz);
+ if (new == NULL) {
+ fprintf(stderr, "Out of memory\n");
+ exit(1);