aboutsummaryrefslogtreecommitdiffstats
path: root/cad/oregano/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/oregano/Makefile')
-rw-r--r--cad/oregano/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/cad/oregano/Makefile b/cad/oregano/Makefile
index f837631738a2..8ef5ae980fd2 100644
--- a/cad/oregano/Makefile
+++ b/cad/oregano/Makefile
@@ -9,24 +9,16 @@ PORTNAME= oregano
PORTVERSION= 0.23
PORTREVISION= 1
CATEGORIES= cad
-MASTER_SITES= ftp://ftp.codefactory.se/pub/CodeFactory/software/oregano/
+MASTER_SITES= http://people.imendio.com/richard/oregano/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Schematic capture and simulation of electrical circuits
-USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_GNOME= gnomehack gnomeprefix gnomeprint libglade
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-pre-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\(\$$(datadir)/\)gnome/|\1|g ; \
- s|\$$(datadir)/locale|$$(prefix)/share/locale|g'
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>