aboutsummaryrefslogtreecommitdiffstats
path: root/cad/veroroute/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/veroroute/Makefile')
-rw-r--r--cad/veroroute/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/cad/veroroute/Makefile b/cad/veroroute/Makefile
new file mode 100644
index 000000000000..f1b913933b87
--- /dev/null
+++ b/cad/veroroute/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= veroroute
+DISTVERSIONPREFIX= V
+DISTVERSION= 174
+DISTVERSIONSUFFIX= _Src
+CATEGORIES= cad
+MASTER_SITES= SF/${PORTNAME}/
+DISTNAME= VeroRoute_${DISTVERSIONFULL}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= PCB (printed circuit board) design software
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../licenses/license_GPLv3.txt
+
+USES= qmake qt:5 zip
+USE_QT= core gui network widgets buildtools_build
+
+WRKSRC= ${WRKDIR}/VeroRoute
+WRKSRC_SUBDIR= Src
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install: # https://sourceforge.net/p/veroroute/tickets/17/
+ ${INSTALL_PROGRAM} ${WRKSRC}/../${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>