aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/dfsongsd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/dfsongsd/Makefile')
-rw-r--r--chinese/dfsongsd/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/chinese/dfsongsd/Makefile b/chinese/dfsongsd/Makefile
new file mode 100644
index 000000000000..6d840c98529d
--- /dev/null
+++ b/chinese/dfsongsd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: DynaComware DFSongSd
+# Date created: 2005/05/08
+# Whom: chinsan <chinsan@mail2000.com.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dfsongsd
+PORTVERSION= 1.0
+CATEGORIES= chinese x11-fonts
+MASTER_SITES= # empty
+DISTNAME= DFSongSd.ttf
+EXTRACT_SUFX=
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Chinese (HKSCS-2001 + CJK A) TrueType fonts
+
+RESTRICTED= "No redistribution or commercial use is allowed."
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+TTF_DEFAULT= ${DISTFILES}
+TTF= ${DISTFILES}
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+
+do-fetch:
+.if !exists (${DISTDIR}/${DISTNAME})
+ECHO_MSG=/usr/bin/printf
+IGNORE=\'s distfile must be downloaded manually from\n\
+\ \ \ \ \ http://glyph.iso10646hk.net/chinese/download_001.html. If you agree\n\
+\ \ \ \ \ with the terms given in the above page, please download ${DISTNAME},\n\
+\ \ \ \ \ put it into ${DISTDIR} and run \'make\' again\n\n.
+.endif
+
+do-install:
+ @${MKDIR} ${FONTSDIR}
+.for ttf in ${TTF}
+ ${INSTALL_DATA} ${DISTDIR}/${TTF} ${FONTSDIR}
+.endfor
+
+.include "${PORTSDIR}/chinese/ttfm/Makefile.ttf"
+.include <bsd.port.post.mk>