aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/font-std/Makefile40
-rw-r--r--chinese/font-std/pkg-descr2
-rw-r--r--chinese/xpdf/Makefile8
-rw-r--r--chinese/xpdf/files/dot.xpdfrc.in4
5 files changed, 50 insertions, 5 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 275ff2e67596..69830b45164f 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -38,6 +38,7 @@
SUBDIR += fcitx
SUBDIR += firebird
SUBDIR += fireflyttf
+ SUBDIR += font-std
SUBDIR += fortunetw
SUBDIR += fqterm
SUBDIR += gb2jis
diff --git a/chinese/font-std/Makefile b/chinese/font-std/Makefile
new file mode 100644
index 000000000000..8017f3b47b8a
--- /dev/null
+++ b/chinese/font-std/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: font-std
+# Date created: 15 May 2009
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= font-std
+PORTVERSION= 0.0.20090515
+CATEGORIES= chinese x11-fonts
+MASTER_SITES= # empty
+DISTFILES= # empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Chinese Standard Fonts
+
+BUILD_DEPENDS= ${LOCALBASE}/share/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf \
+ ${LOCALBASE}/share/fonts/TrueType/gbsn00lp.ttf:${PORTSDIR}/chinese/arphicttf \
+ ${LOCALBASE}/share/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf \
+ ${LOCALBASE}/share/fonts/TrueType/gkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
+
+NO_BUILD= yes
+PLIST_FILES= ${FONTSDIR}/std.zh_CN/STHeiti-Regular \
+ ${FONTSDIR}/std.zh_CN/STSong-Light \
+ ${FONTSDIR}/std.zh_CN/MSung-Light \
+ ${FONTSDIR}/std.zh_CN/MHei-Medium
+PLIST_DIRS= ${FONTSDIR}/std.zh_CN
+FONTSDIR= ${PREFIX}/share/fonts
+
+do-fetch:
+ @${DO_NADA}
+
+do-install:
+ ${MKDIR} ${FONTSDIR}/std.zh_CN
+ ${LN} -s -f ${LOCALBASE}/share/fonts/TrueType/bkai00mp.ttf ${FONTSDIR}/std.zh_CN/STHeiti-Regular
+ ${LN} -s -f ${LOCALBASE}/share/fonts/TrueType/gbsn00lp.ttf ${FONTSDIR}/std.zh_CN/STSong-Light
+ ${LN} -s -f ${LOCALBASE}/share/fonts/TrueType/bsmi00lp.ttf ${FONTSDIR}/std.zh_CN/MSung-Light
+ ${LN} -s -f ${LOCALBASE}/share/fonts/TrueType/gkai00mp.ttf ${FONTSDIR}/std.zh_CN/MHei-Medium
+
+.include <bsd.port.mk>
diff --git a/chinese/font-std/pkg-descr b/chinese/font-std/pkg-descr
new file mode 100644
index 000000000000..50ef9d65aa22
--- /dev/null
+++ b/chinese/font-std/pkg-descr
@@ -0,0 +1,2 @@
+This port installs standard fonts for Chinese used in the Ports
+Collection.
diff --git a/chinese/xpdf/Makefile b/chinese/xpdf/Makefile
index 8f91d496a271..4419149415d9 100644
--- a/chinese/xpdf/Makefile
+++ b/chinese/xpdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xpdf
PORTVERSION= 3.02
-PORTEPOCH= 1
+PORTEPOCH= 2
CATEGORIES= chinese graphics print
MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN} \
@@ -22,7 +22,9 @@ COMMENT= Chinese font support for xpdf
RUN_DEPENDS= xpdf:${PORTSDIR}/graphics/xpdf \
${ADOBECMAPDIR}/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps \
- ${FONTSDIR}/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
+ ${FONTSDIR}/STHeiti-Regular:${PORTSDIR}/chinese/font-std \
+ ${FONTSDIR}/STSong-Light:${PORTSDIR}/chinese/font-std \
+ ${FONTSDIR}/MSung-Light:${PORTSDIR}/chinese/font-std
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -32,7 +34,7 @@ SUB_LIST= ADOBECMAPDIR=${ADOBECMAPDIR} \
PLIST_SUB= EXTRARC=${EXTRARC}
DATADIR= ${PREFIX}/share/xpdf
-FONTSDIR= ${LOCALBASE}/share/fonts/TrueType
+FONTSDIR= ${LOCALBASE}/share/fonts/std.zh_CN
EXTRARC= ${DATADIR}/chinese-traditional/dot.xpdfrc
ADOBECMAPDIR= ${LOCALBASE}/share/fonts/adobe-cmaps
SIMP_FILES= Adobe-GB1.cidToUnicode EUC-CN.unicodeMap GBK.unicodeMap \
diff --git a/chinese/xpdf/files/dot.xpdfrc.in b/chinese/xpdf/files/dot.xpdfrc.in
index 3d0d8dd9c176..0a3163d1422f 100644
--- a/chinese/xpdf/files/dot.xpdfrc.in
+++ b/chinese/xpdf/files/dot.xpdfrc.in
@@ -4,7 +4,7 @@ unicodeMap Big5 %%DATADIR%%/chinese-traditional/Big5.unicodeMap
unicodeMap Big5ascii %%DATADIR%%/chinese-traditional/Big5ascii.unicodeMap
cMapDir Adobe-CNS1 %%ADOBECMAPDIR%%
toUnicodeDir %%ADOBECMAPDIR%%
-displayCIDFontTT Adobe-CNS1 %%FONTSDIR%%/bkai00mp.ttf
+displayCIDFontTT Adobe-CNS1 %%FONTSDIR%%/STHeiti-Regular
#----- end Chinese Traditional support package
#----- begin Chinese Simplified support package (2004-jul-27)
cidToUnicode Adobe-GB1 %%DATADIR%%/chinese-simplified/Adobe-GB1.cidToUnicode
@@ -13,5 +13,5 @@ unicodeMap EUC-CN %%DATADIR%%/chinese-simplified/EUC-CN.unicodeMap
unicodeMap GBK %%DATADIR%%/chinese-simplified/GBK.unicodeMap
cMapDir Adobe-GB1 %%ADOBECMAPDIR%%
toUnicodeDir %%ADOBECMAPDIR%%
-displayCIDFontTT Adobe-GB1 %%FONTSDIR%%/gkai00mp.ttf
+displayCIDFontTT Adobe-GB1 %%FONTSDIR%%/STSong-Light
#----- end Chinese Simplified support package