aboutsummaryrefslogtreecommitdiffstats
path: root/comms/librs232/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/librs232/Makefile')
-rw-r--r--comms/librs232/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/comms/librs232/Makefile b/comms/librs232/Makefile
index e2a2d8c9e010..428d3689588f 100644
--- a/comms/librs232/Makefile
+++ b/comms/librs232/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= librs232
-PORTVERSION= 20140105
+PORTVERSION= 20141206
CATEGORIES= comms
DISTNAME= RS-232
MASTER_SITES= http://www.teuniz.net/RS-232/
@@ -10,19 +10,26 @@ MAINTAINER= kevlo@FreeBSD.org
COMMENT= Simple serial library
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/gpl.txt
WRKSRC= ${WRKDIR}
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
USES= uidfix
USE_LDCONFIG= yes
+PORTEXAMPLES= demo_rx.c demo_tx.c
+
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
.include <bsd.port.mk>