aboutsummaryrefslogtreecommitdiffstats
path: root/comms/openzwave-devel/files/patch-cpp_build_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/openzwave-devel/files/patch-cpp_build_Makefile')
-rw-r--r--comms/openzwave-devel/files/patch-cpp_build_Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/comms/openzwave-devel/files/patch-cpp_build_Makefile b/comms/openzwave-devel/files/patch-cpp_build_Makefile
index 3a2f4199067d..15d3f4c97853 100644
--- a/comms/openzwave-devel/files/patch-cpp_build_Makefile
+++ b/comms/openzwave-devel/files/patch-cpp_build_Makefile
@@ -1,5 +1,18 @@
---- cpp/build/Makefile.orig 2019-08-26 02:51:02 UTC
+--- cpp/build/Makefile.orig 2020-03-16 04:03:45 UTC
+++ cpp/build/Makefile
+@@ -13,10 +13,10 @@
+
+
+ # what flags we will use for compiling in debug mode
+-DEBUG_CFLAGS := -Wformat -Wall -Wno-unknown-pragmas -Wno-inline -Werror -Wno-error=sequence-point -Wno-sequence-point -ggdb -DDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
++DEBUG_CFLAGS := -Wformat -Wall -Wno-unknown-pragmas -Wno-inline -Wno-error=sequence-point -Wno-sequence-point -ggdb -DDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
+ DEBUG_CPPFLAGS := -std=c++11
+ # what flags we will use for compiling in release mode
+-RELEASE_CFLAGS := -Wall -Wno-unknown-pragmas -Werror -Wno-error=sequence-point -Wno-sequence-point -O3 -DNDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
++RELEASE_CFLAGS := -Wall -Wno-unknown-pragmas -Wno-error=sequence-point -Wno-sequence-point -O3 -DNDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
+ RELEASE_CPPFLAGS := -std=c++11
+ #what flags we will use for linking in debug mode
+ DEBUG_LDFLAGS := -g
@@ -280,8 +280,8 @@ install: $(LIBDIR)/$(SHARED_LIB_NAME) doc $(top_buildd
@cp -r $(top_srcdir)/docs/* $(DESTDIR)/$(docdir)
@if [ -d "$(top_builddir)/docs/html/" ]; then cp -r $(top_builddir)/docs/html/* $(DESTDIR)/$(docdir); fi