aboutsummaryrefslogtreecommitdiffstats
path: root/comms/smstools3/files/patch-src-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/smstools3/files/patch-src-Makefile')
-rw-r--r--comms/smstools3/files/patch-src-Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/comms/smstools3/files/patch-src-Makefile b/comms/smstools3/files/patch-src-Makefile
new file mode 100644
index 000000000000..6f6d7ab1fd2f
--- /dev/null
+++ b/comms/smstools3/files/patch-src-Makefile
@@ -0,0 +1,20 @@
+--- src/Makefile.orig 2008-11-21 11:41:21.000000000 +0100
++++ src/Makefile 2008-11-21 11:42:39.000000000 +0100
+@@ -6,7 +6,7 @@
+ # CC=gcc
+
+ # Comment this out, to enable statistics
+-CFLAGS += -D NOSTATS
++#CFLAGS += -D NOSTATS
+
+ # Uncomment this to force smsd to run in terminal mode
+ #CFLAGS += -D TERMINAL
+@@ -24,7 +24,7 @@
+ ifneq (,$(findstring NOSTATS,$(CFLAGS)))
+ $(CC) $(CFLAGS) -o $@ $^
+ else
+- $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs`
++ $(CC) `$(LOCALBASE)/bin/mm-config --cflags` $(CFLAGS) -o $@ $^ `$(LOCALBASE)/bin/mm-config --ldflags --libs`
+ @echo "(Please ignore warning about tempnam -- it is used in a safe way)"
+ endif
+