aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/deforaos-phone/Makefile29
-rw-r--r--comms/deforaos-phone/distinfo2
-rw-r--r--comms/deforaos-phone/files/patch-src-modems-hayes.c3
-rw-r--r--comms/deforaos-phone/files/patch-src-plugins-Makefile11
-rw-r--r--comms/deforaos-phone/pkg-descr3
-rw-r--r--comms/deforaos-phone/pkg-plist66
7 files changed, 115 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 13f273f60dac..69fd2aedbd9e 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -25,6 +25,7 @@
SUBDIR += conserver-com
SUBDIR += cutecom
SUBDIR += cwdaemon
+ SUBDIR += deforaos-phone
SUBDIR += dfu-programmer
SUBDIR += dfu-util
SUBDIR += ebook2cw
diff --git a/comms/deforaos-phone/Makefile b/comms/deforaos-phone/Makefile
new file mode 100644
index 000000000000..c0f02d6bc41f
--- /dev/null
+++ b/comms/deforaos-phone/Makefile
@@ -0,0 +1,29 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= phone
+PORTVERSION= 0.3.10
+CATEGORIES= comms
+MASTER_SITES= http://www.defora.org/os/download/download/3707/
+DISTNAME= Phone-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS telephony application
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
+ Desktop:${PORTSDIR}/x11/deforaos-libdesktop \
+ pulse:${PORTSDIR}/audio/pulseaudio \
+ purple:${PORTSDIR}/net-im/libpurple \
+ sofia-sip-ua:${PORTSDIR}/net/sofia-sip
+BUILD_DEPENDS= locker:${PORTSDIR}/x11/deforaos-locker \
+ ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
+
+USE_GNOME= gtk20 desktopfileutils
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/comms/deforaos-phone/distinfo b/comms/deforaos-phone/distinfo
new file mode 100644
index 000000000000..bdda3f7ace59
--- /dev/null
+++ b/comms/deforaos-phone/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Phone-0.3.10.tar.gz) = b987b86b58cf6afa6fed88bb6edaaabeef32eb72bc0c6d75bab60b807888f016
+SIZE (Phone-0.3.10.tar.gz) = 166197
diff --git a/comms/deforaos-phone/files/patch-src-modems-hayes.c b/comms/deforaos-phone/files/patch-src-modems-hayes.c
new file mode 100644
index 000000000000..ea8f6aa724fb
--- /dev/null
+++ b/comms/deforaos-phone/files/patch-src-modems-hayes.c
@@ -0,0 +1,3 @@
+d2108 1
+a2108 1
+ device = "/dev/cuaU0";
diff --git a/comms/deforaos-phone/files/patch-src-plugins-Makefile b/comms/deforaos-phone/files/patch-src-plugins-Makefile
new file mode 100644
index 000000000000..2cb4f3240ea4
--- /dev/null
+++ b/comms/deforaos-phone/files/patch-src-plugins-Makefile
@@ -0,0 +1,11 @@
+--- src/plugins/Makefile.orig 2012-06-24 15:48:33.000000000 +0200
++++ src/plugins/Makefile 2012-06-24 15:48:43.000000000 +0200
+@@ -73,7 +73,7 @@
+
+ oss_OBJS = oss.o
+ oss_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) $(CFLAGSF) $(CFLAGS)
+-oss_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) -lossaudio
++oss_LDFLAGS = $(LDFLAGSF) $(LDFLAGS)
+
+ oss.so: $(oss_OBJS)
+ $(CCSHARED) -o oss.so $(oss_OBJS) $(oss_LDFLAGS)
diff --git a/comms/deforaos-phone/pkg-descr b/comms/deforaos-phone/pkg-descr
new file mode 100644
index 000000000000..64b8ccc58283
--- /dev/null
+++ b/comms/deforaos-phone/pkg-descr
@@ -0,0 +1,3 @@
+DeforaOS telephony application
+
+WWW: http://www.defora.org/
diff --git a/comms/deforaos-phone/pkg-plist b/comms/deforaos-phone/pkg-plist
new file mode 100644
index 000000000000..c2afc69e2dc3
--- /dev/null
+++ b/comms/deforaos-phone/pkg-plist
@@ -0,0 +1,66 @@
+bin/phone
+bin/phonectl
+include/Desktop/Phone.h
+include/Desktop/Phone/modem.h
+include/Desktop/Phone/modems/hayes.h
+include/Desktop/Phone/phone.h
+include/Desktop/Phone/plugin.h
+lib/Phone/modem/debug.so
+lib/Phone/modem/hayes.so
+lib/Phone/modem/purple.so
+lib/Phone/modem/sofia.so
+lib/Phone/plugins/blacklist.so
+lib/Phone/plugins/debug.so
+lib/Phone/plugins/engineering.so
+lib/Phone/plugins/gprs.so
+lib/Phone/plugins/gps.so
+lib/Phone/plugins/locker.so
+lib/Phone/plugins/n900.so
+lib/Phone/plugins/openmoko.so
+lib/Phone/plugins/oss.so
+lib/Phone/plugins/panel.so
+lib/Phone/plugins/profiles.so
+lib/Phone/plugins/smscrypt.so
+lib/Phone/plugins/systray.so
+lib/Phone/plugins/ussd.so
+share/applications/phone-contacts.desktop
+share/applications/phone-dialer.desktop
+share/applications/phone-log.desktop
+share/applications/phone-messages.desktop
+share/applications/phone-settings.desktop
+share/icons/hicolor/16x16/apps/phone-dialer.png
+share/icons/hicolor/16x16/apps/phone-drafts.png
+share/icons/hicolor/16x16/apps/phone-inbox.png
+share/icons/hicolor/16x16/apps/phone-n900.png
+share/icons/hicolor/16x16/apps/phone-openmoko.png
+share/icons/hicolor/16x16/apps/phone-roaming.png
+share/icons/hicolor/16x16/apps/phone-sent.png
+share/icons/hicolor/22x22/apps/phone-dialer.png
+share/icons/hicolor/22x22/apps/phone-signal-00.png
+share/icons/hicolor/22x22/apps/phone-signal-100.png
+share/icons/hicolor/22x22/apps/phone-signal-25.png
+share/icons/hicolor/22x22/apps/phone-signal-50.png
+share/icons/hicolor/22x22/apps/phone-signal-75.png
+share/icons/hicolor/24x24/apps/phone-dialer.png
+share/icons/hicolor/24x24/apps/phone-drafts.png
+share/icons/hicolor/24x24/apps/phone-inbox.png
+share/icons/hicolor/24x24/apps/phone-n900.png
+share/icons/hicolor/24x24/apps/phone-openmoko.png
+share/icons/hicolor/24x24/apps/phone-roaming.png
+share/icons/hicolor/24x24/apps/phone-sent.png
+share/icons/hicolor/32x32/apps/phone-dialer.png
+share/icons/hicolor/32x32/apps/phone-n900.png
+share/icons/hicolor/32x32/apps/phone-openmoko.png
+share/icons/hicolor/32x32/apps/phone-roaming.png
+share/icons/hicolor/48x48/apps/phone-dialer.png
+share/icons/hicolor/48x48/apps/phone-inbox.png
+share/icons/hicolor/48x48/apps/phone-n900.png
+share/icons/hicolor/48x48/apps/phone-openmoko.png
+share/icons/hicolor/48x48/apps/phone-roaming.png
+share/icons/hicolor/48x48/apps/phone-sent.png
+share/locale/fr/LC_MESSAGES/Phone.mo
+@dirrm include/Desktop/Phone/modems
+@dirrm include/Desktop/Phone
+@dirrm lib/Phone/modem
+@dirrm lib/Phone/plugins
+@dirrm lib/Phone