aboutsummaryrefslogtreecommitdiffstats
path: root/databases/gtksql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/gtksql/Makefile')
-rw-r--r--databases/gtksql/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index e1895669e577..8d58eed3dcff 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -29,6 +29,9 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS+= -I${LOCALBASE}/include/scintilla -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lscintilla -lscintilla_lexers
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_WITH= postgresql
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAVAHI}
@@ -45,12 +48,6 @@ LDFLAGS+= -L${LOCALBASE}/lib/mysql
CONFIGURE_ARGS+= --without-mysql
.endif
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-.else
-CONFIGURE_ARGS+= --without-postgresql
-.endif
-
.if ${PORT_OPTIONS:MSQLITE}
USE_SQLITE= yes
.else