aboutsummaryrefslogtreecommitdiffstats
path: root/databases/rrdtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/rrdtool/Makefile')
-rw-r--r--databases/rrdtool/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 80dbc4453d6a..8fbc5a49e27d 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rrdtool
-PORTVERSION= 1.2.26
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= databases graphics
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/
@@ -15,8 +14,10 @@ MAINTAINER= bg1tpt@gmail.com
COMMENT= Round Robin Database Tools
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
- png.5:${PORTSDIR}/graphics/png
+ cairo.2:${PORTSDIR}/graphics/cairo \
+ png.5:${PORTSDIR}/graphics/png \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ pangocairo-1\.0.0:${PORTSDIR}/x11-toolkits/pango
CONFLICTS= rrdtool-1.0*
@@ -63,7 +64,7 @@ PLIST_SUB+= WITH_PERL="@comment "
.endif
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libart-2.0 -I${LOCALBASE}/include/freetype2
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"