aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-Class-DBI-Replication/Makefile2
-rw-r--r--databases/p5-DBD-XBase/Makefile4
-rw-r--r--databases/p5-DBIx-TableHash/Makefile2
-rw-r--r--databases/p5-MLDBM/Makefile2
-rw-r--r--databases/p5-POE-Component-DBIAgent/Makefile6
-rw-r--r--databases/p5-ResourcePool-Resource-DBI/Makefile4
6 files changed, 10 insertions, 10 deletions
diff --git a/databases/p5-Class-DBI-Replication/Makefile b/databases/p5-Class-DBI-Replication/Makefile
index cd406029b0b3..3ead5b787083 100644
--- a/databases/p5-Class-DBI-Replication/Makefile
+++ b/databases/p5-Class-DBI-Replication/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Class::DBI for replicated database
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBD-XBase/Makefile b/databases/p5-DBD-XBase/Makefile
index 1873d3fa3f96..2f4aaebf5175 100644
--- a/databases/p5-DBD-XBase/Makefile
+++ b/databases/p5-DBD-XBase/Makefile
@@ -13,8 +13,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provides access to XBase (dBase, Fox*) database files through DBI
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBIx-TableHash/Makefile b/databases/p5-DBIx-TableHash/Makefile
index 369c007597c7..24656feba005 100644
--- a/databases/p5-DBIx-TableHash/Makefile
+++ b/databases/p5-DBIx-TableHash/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Tie a hash to a mysql table + SQL utils
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+BUILD_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-MLDBM/Makefile b/databases/p5-MLDBM/Makefile
index 495462d123c0..09018a2659c9 100644
--- a/databases/p5-MLDBM/Makefile
+++ b/databases/p5-MLDBM/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Store multi-level hash structure in single level tied hash
-BUILD_DEPENDS= ${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
+BUILD_DEPENDS= p5-FreezeThaw>=0:${PORTSDIR}/devel/p5-FreezeThaw
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-POE-Component-DBIAgent/Makefile b/databases/p5-POE-Component-DBIAgent/Makefile
index 86c0b59c0d0b..9c8c26ceaced 100644
--- a/databases/p5-POE-Component-DBIAgent/Makefile
+++ b/databases/p5-POE-Component-DBIAgent/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= POE Component for running asynchronous DBI calls
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/${PERL_ARCH}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Class-MethodMaker>=0:${PORTSDIR}/devel/p5-Class-MethodMaker \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-ResourcePool-Resource-DBI/Makefile b/databases/p5-ResourcePool-Resource-DBI/Makefile
index b99a99a03ed9..b18d31df810e 100644
--- a/databases/p5-ResourcePool-Resource-DBI/Makefile
+++ b/databases/p5-ResourcePool-Resource-DBI/Makefile
@@ -16,8 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= ResourcePool::Resource::DBI - A ResourcePool wrapper for DBI
-BUILD_DEPENDS= ${SITE_PERL}/ResourcePool.pm:${PORTSDIR}/devel/p5-ResourcePool \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-ResourcePool>=0:${PORTSDIR}/devel/p5-ResourcePool \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes