aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-ContextualFetch/Makefile36
-rw-r--r--databases/p5-DBIx-ContextualFetch/distinfo2
-rw-r--r--databases/p5-DBIx-ContextualFetch/pkg-descr7
-rw-r--r--databases/p5-DBIx-ContextualFetch/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cc421fde1609..d94bd19e2cb4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -144,6 +144,7 @@
SUBDIR += p5-DBIWrapper
SUBDIR += p5-DBIx-AnyDBD
SUBDIR += p5-DBIx-Browse
+ SUBDIR += p5-DBIx-ContextualFetch
SUBDIR += p5-DBIx-DBSchema
SUBDIR += p5-DBIx-DataSource
SUBDIR += p5-DBIx-Ease
diff --git a/databases/p5-DBIx-ContextualFetch/Makefile b/databases/p5-DBIx-ContextualFetch/Makefile
new file mode 100644
index 000000000000..dd0d04cadf57
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: DBIx-ContextualFetch
+# Date created: 17 March 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-ContextualFetch
+PORTVERSION= 1.01
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx/TMTM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Add contextual fetches to DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::ContextualFetch.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-ContextualFetch/distinfo b/databases/p5-DBIx-ContextualFetch/distinfo
new file mode 100644
index 000000000000..838d673ea2ec
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/distinfo
@@ -0,0 +1,2 @@
+MD5 (DBIx-ContextualFetch-1.01.tar.gz) = d36c5244c73a973a945b9294b619fe49
+SIZE (DBIx-ContextualFetch-1.01.tar.gz) = 3594
diff --git a/databases/p5-DBIx-ContextualFetch/pkg-descr b/databases/p5-DBIx-ContextualFetch/pkg-descr
new file mode 100644
index 000000000000..50c9b176df65
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/pkg-descr
@@ -0,0 +1,7 @@
+DBIx::ContextualFetch redefines some of the various fetch methods to
+add context sensitivity.
+
+WWW: http://search.cpan.org/dist/DBIx-ContextualFetch/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/databases/p5-DBIx-ContextualFetch/pkg-plist b/databases/p5-DBIx-ContextualFetch/pkg-plist
new file mode 100644
index 000000000000..88122395b8de
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/ContextualFetch/.packlist
+%%SITE_PERL%%/DBIx/ContextualFetch.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/ContextualFetch
+@unexec rmdir %D/%%SITE_PERL%%/DBIx 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true