aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/akonadi-kde4/Makefile71
-rw-r--r--databases/akonadi-kde4/distinfo2
-rw-r--r--databases/akonadi-kde4/files/patch-cmake__modules__FindSqlite.cmake32
-rw-r--r--databases/akonadi-kde4/files/patch-git_2146519170
-rw-r--r--databases/akonadi-kde4/files/patch-server__src__storage__dbconfigmysql.cpp11
-rw-r--r--databases/akonadi-kde4/pkg-descr6
-rw-r--r--databases/akonadi-kde4/pkg-plist44
8 files changed, 0 insertions, 237 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ff2c49249d0b..f98983680e4e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -15,7 +15,6 @@
SUBDIR += adodb
SUBDIR += adodb5
SUBDIR += akonadi
- SUBDIR += akonadi-kde4
SUBDIR += apq
SUBDIR += apq-mysql
SUBDIR += apq-odbc
diff --git a/databases/akonadi-kde4/Makefile b/databases/akonadi-kde4/Makefile
deleted file mode 100644
index 5c86a50038e7..000000000000
--- a/databases/akonadi-kde4/Makefile
+++ /dev/null
@@ -1,71 +0,0 @@
-# Created by: miwi
-# $FreeBSD$
-
-PORTNAME= akonadi
-PORTVERSION= 1.13.0
-PORTREVISION= 10
-CATEGORIES= databases kde
-MASTER_SITES= KDE/stable/${PORTNAME}/src
-PKGNAMESUFFIX= -kde4
-DIST_SUBDIR= KDE
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Storage server for KDE-Pim
-
-LICENSE= LGPL21
-
-DEPRECATED= KDE4 is EOL upstream
-EXPIRATION_DATE= 2018-12-31
-
-LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-# Let process generate meaningful backtrace on core dump.
-BUILD_DEPENDS= xsltproc:textproc/libxslt
-
-USES= cmake kde:4 qt:4 shared-mime-info \
- compiler:c++11-lang pathfix tar:bzip2
-USE_KDE= automoc4 soprano
-USE_QT= corelib dbus gui network qtestlib_build sql xml \
- moc_build qmake_build rcc_build uic_build
-CMAKE_ARGS+= -DAKONADI_BUILD_TESTS:BOOL=FALSE \
- -DINSTALL_QSQLITE_IN_QT_PREFIX:BOOL=TRUE \
- -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"
-USE_LDCONFIG= yes
-
-OPTIONS_MULTI= DB
-OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
-OPTIONS_SUB= yes # SQLITE
-
-MYSQL_DESC= Install MySQL Qt plugin and server
-MYSQL_USE= QT=sql-mysql_run
-MYSQL_USES= mysql:server qt:4
-
-PGSQL_DESC= Install PostgreSQL Qt plugin
-# Do not add a dependency on PostgreSQL server as someone preferring
-# it over MySQL might like to use some advanced configuration, like a
-# remote server.
-#PGSQL_USE= PGSQL=server
-PGSQL_USES= qt:4
-PGSQL_USE= QT=sql-pgsql_run
-
-SQLITE_DESC= Enable SQLite backend
-SQLITE_USES= sqlite:3
-SQLITE_CMAKE_OFF= -DAKONADI_BUILD_QSQLITE=off
-
-OPTIONS_DEFAULT= MYSQL
-
-post-patch:
- ${REINPLACE_CMD} -e '/find_program/ s|mysqld|mysqld_safe ${LOCALBASE}/bin|g' \
- ${PATCH_WRKSRC}/server/CMakeLists.txt
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${PATCH_WRKSRC}/server/src/storage/dbconfigmysql.cpp
-# To avoid overflow, MySQL settings need to be lower than
-# INT_MAX / kern.hz. This setting assumes kern.hz=2000, and
-# it's nothing but a temporary hack.
- ${REINPLACE_CMD} -e '/wait_timeout/ s|31536000|1073741|' \
- ${PATCH_WRKSRC}/server/src/storage/*.conf
-# Prevent updating MIME during build.
- ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
- -e '/find_package(SharedMimeInfo/ d' \
- ${PATCH_WRKSRC}/CMakeLists.txt
-
-.include <bsd.port.mk>
diff --git a/databases/akonadi-kde4/distinfo b/databases/akonadi-kde4/distinfo
deleted file mode 100644
index 642fcd3e4eea..000000000000
--- a/databases/akonadi-kde4/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (KDE/akonadi-1.13.0.tar.bz2) = 8c7f690002ea22c139f3a64394aef2e816e00ca47fd971af7d54a66087356dd2
-SIZE (KDE/akonadi-1.13.0.tar.bz2) = 294198
diff --git a/databases/akonadi-kde4/files/patch-cmake__modules__FindSqlite.cmake b/databases/akonadi-kde4/files/patch-cmake__modules__FindSqlite.cmake
deleted file mode 100644
index 93d59a9d74e9..000000000000
--- a/databases/akonadi-kde4/files/patch-cmake__modules__FindSqlite.cmake
+++ /dev/null
@@ -1,32 +0,0 @@
-commit b60702e0b7041c56a3cb52c209204d28406f3ce5
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Wed Aug 13 14:43:04 2014 +0300
-
- FindSqlite: Use CMAKE_FLAGS the right way in try_compile().
-
- This fixes f90774f1 ("Check whether Sqlite is compiled with
- SQLITE_ENABLE_UNLOCK_NOTIFY"), so that SQLITE_INCLUDE_DIR is really
- passed to the try_compile() call. So far, it was just a NOP and the
- compilation only worked if sqlite3.h was in a directory the compiler
- uses automatically.
-
- try_compile()'s syntax is a bit complicated, and CMAKE_FLAGS expects a
- series of arguments as if they had been passed to the command line, so
- instead of "CMAKE_FLAGS INCLUDE_DIRECTORIES /some/dir" one needs to use
- "CMAKE_FLAGS -DINCLUDE_DIRECTORIES:PATH=/some/dir".
-
- REVIEW: 119762
-
-diff --git a/cmake/modules/FindSqlite.cmake b/cmake/modules/FindSqlite.cmake
-index ad8cdb4..c43a7b5 100644
---- cmake/modules/FindSqlite.cmake
-+++ cmake/modules/FindSqlite.cmake
-@@ -94,7 +94,7 @@ if(EXISTS ${SQLITE_INCLUDE_DIR}/sqlite3.h)
- ${CMAKE_BINARY_DIR}/sqlite_check_unlock_notify
- ${CMAKE_BINARY_DIR}/sqlite_check_unlock_notify.cpp
- LINK_LIBRARIES ${SQLITE_LIBRARIES}
-- CMAKE_FLAGS INCLUDE_DIRECTORIES ${SQLITE_INCLUDE_DIR})
-+ CMAKE_FLAGS "-DINCLUDE_DIRECTORIES:PATH=${SQLITE_INCLUDE_DIR}")
- if (NOT SQLITE_HAS_UNLOCK_NOTIFY)
- message(STATUS "Sqlite ${SQLITE_VERSION} was found, but it is not compiled with -DSQLITE_ENABLE_UNLOCK_NOTIFY")
- endif()
diff --git a/databases/akonadi-kde4/files/patch-git_21465191 b/databases/akonadi-kde4/files/patch-git_21465191
deleted file mode 100644
index 43eb8f78c3a1..000000000000
--- a/databases/akonadi-kde4/files/patch-git_21465191
+++ /dev/null
@@ -1,70 +0,0 @@
-commit 2146519108ec66300328b7b3979477c7789795d3
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Wed Aug 13 23:22:11 2014 +0300
-
- Do not enter the test/ directories if AKONADI_BUILD_TESTS is off.
-
- enable_testing() only determines whether a "test" target and the related
- CTest files will be created. And in Akonadi's case it is actually
- invoked regardless of the value of the AKONADI_BUILD_TESTS option
- because Akonadi includes the CTest module, which calls enable_testing()
- based on the value of another variable, BUILD_TESTING.
-
- In any case, whether the executables and libraries that compose
- Akonadi's unit tests will be built has nothing to do with
- enable_testing(). To make AKONADI_BUILD_TESTS really disable the build
- of the unit tests we now avoid entering the tests/ directories at all
- when it is off, so that neither tests nor targets they depend on get
- built.
-
- REVIEW: 119776
-
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -14,7 +14,7 @@ include(FeatureSummary)
-
- ############### Build Options ###############
-
--include(CTest)
-+include(CTest) # Calls enable_testing().
- include(CTestConfig.cmake)
- option(AKONADI_BUILD_TESTS "Build the Akonadi unit tests." TRUE)
- option(AKONADI_BUILD_QSQLITE "Build the Sqlite backend." TRUE)
-@@ -27,10 +27,6 @@ if(NOT DEFINED DATABASE_BACKEND)
- set(DATABASE_BACKEND "MYSQL" CACHE STRING "The default database backend to use for Akonadi. Can be either MYSQL, POSTGRES or SQLITE")
- endif()
-
--if(AKONADI_BUILD_TESTS)
-- enable_testing()
--endif()
--
- ############### CMake Macros ###############
-
- include(InstallSettings)
---- libs/CMakeLists.txt
-+++ libs/CMakeLists.txt
-@@ -36,5 +36,7 @@ install(FILES
- DESTINATION ${INCLUDE_INSTALL_DIR}/akonadi/private
- )
-
--add_subdirectory(tests)
-+if(AKONADI_BUILD_TESTS)
-+ add_subdirectory(tests)
-+endif()
-
-diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
-index e4829f3..275938d 100644
---- server/CMakeLists.txt
-+++ server/CMakeLists.txt
-@@ -64,7 +64,10 @@ endmacro()
- add_subdirectory(akonadictl)
- add_subdirectory(control)
- add_subdirectory(src)
--add_subdirectory(tests)
-+
-+if(AKONADI_BUILD_TESTS)
-+ add_subdirectory(tests)
-+endif()
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${_ENABLE_EXCEPTIONS}")
- if(MYSQLD_EXECUTABLE)
diff --git a/databases/akonadi-kde4/files/patch-server__src__storage__dbconfigmysql.cpp b/databases/akonadi-kde4/files/patch-server__src__storage__dbconfigmysql.cpp
deleted file mode 100644
index ffa3aaae1de4..000000000000
--- a/databases/akonadi-kde4/files/patch-server__src__storage__dbconfigmysql.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./server/src/storage/dbconfigmysql.cpp.orig 2012-06-13 02:11:19.473370856 +0200
-+++ ./server/src/storage/dbconfigmysql.cpp 2012-06-13 02:11:50.113468897 +0200
-@@ -265,7 +265,7 @@ void DbConfigMysql::startInternalServer()
- // first run, some MySQL versions need a mysql_install_db run for that
- const QString confFile = XdgBaseDirs::findResourceFile( "config", QLatin1String( "akonadi/mysql-global.conf" ) );
- if ( QDir( dataDir ).entryList( QDir::NoDotAndDotDot | QDir::AllEntries ).isEmpty() && !mMysqlInstallDbPath.isEmpty() ) {
-- const QStringList arguments = QStringList() << QString::fromLatin1( "--force" ) << QString::fromLatin1( "--defaults-file=%1" ).arg( confFile ) << QString::fromLatin1( "--datadir=%1/" ).arg( dataDir );
-+ const QStringList arguments = QStringList() << QString::fromLatin1( "--force" ) << QString::fromLatin1( "--defaults-file=%1" ).arg( confFile ) << QString::fromLatin1( "--datadir=%1/" ).arg( dataDir ) << QString::fromLatin1( "--basedir=%%LOCALBASE%%" );
- QProcess::execute( mMysqlInstallDbPath, arguments );
- }
-
diff --git a/databases/akonadi-kde4/pkg-descr b/databases/akonadi-kde4/pkg-descr
deleted file mode 100644
index f19c69404f3f..000000000000
--- a/databases/akonadi-kde4/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-The Akonadi framework is responsible for providing applications with a
-centralized database to store, index and retrieve the user's personal
-information. This includes the user's emails, contacts, calendars,
-events, journals, alarms, notes, etc.
-
-WWW: https://community.kde.org/KDE_PIM/Akonadi
diff --git a/databases/akonadi-kde4/pkg-plist b/databases/akonadi-kde4/pkg-plist
deleted file mode 100644
index 68e4ed46c11e..000000000000
--- a/databases/akonadi-kde4/pkg-plist
+++ /dev/null
@@ -1,44 +0,0 @@
-bin/akonadi_agent_launcher
-bin/akonadi_agent_server
-bin/akonadi_control
-bin/akonadi_rds
-bin/akonadictl
-bin/akonadiserver
-bin/asapcat
-include/akonadi/abstractsearchplugin.h
-include/akonadi/private/akonadiprotocolinternals_export.h
-include/akonadi/private/capabilities_p.h
-include/akonadi/private/imapparser_p.h
-include/akonadi/private/imapset_p.h
-include/akonadi/private/notificationmessage_p.h
-include/akonadi/private/notificationmessagev2_p.h
-include/akonadi/private/notificationmessagev3_p.h
-include/akonadi/private/protocol_p.h
-include/akonadi/private/xdgbasedirs_p.h
-lib/cmake/Akonadi/AkonadiConfig.cmake
-lib/cmake/Akonadi/AkonadiConfigVersion.cmake
-lib/cmake/Akonadi/AkonadiTargetsWithPrefix-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/Akonadi/AkonadiTargetsWithPrefix.cmake
-lib/libakonadiprotocolinternals.so
-lib/libakonadiprotocolinternals.so.1
-lib/libakonadiprotocolinternals.so.1.13.0
-libdata/pkgconfig/akonadi.pc
-share/config/akonadi/mysql-global-mobile.conf
-share/config/akonadi/mysql-global.conf
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Control.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Search.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Agent.Status.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.AgentManager.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.ControlManager.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.DebugInterface.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.NotificationManager.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.NotificationSource.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Preprocessor.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Resource.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Server.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.StorageDebugger.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.Tracer.xml
-share/dbus-1/interfaces/org.freedesktop.Akonadi.TracerNotification.xml
-share/dbus-1/services/org.freedesktop.Akonadi.Control.service
-share/mime/packages/akonadi-mime.xml
-%%SQLITE%%%%QT_PLUGINDIR%%/sqldrivers/libqsqlite3.so