aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php7-tarantool/Makefile24
-rw-r--r--databases/php7-tarantool/distinfo3
-rw-r--r--databases/php7-tarantool/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3f33c43760a5..af632fad79cb 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -626,6 +626,7 @@
SUBDIR += php56-pgsql
SUBDIR += php56-sqlite3
SUBDIR += php56-sybase_ct
+ SUBDIR += php7-tarantool
SUBDIR += php70-dba
SUBDIR += php70-interbase
SUBDIR += php70-memcache
diff --git a/databases/php7-tarantool/Makefile b/databases/php7-tarantool/Makefile
new file mode 100644
index 000000000000..637dd46ec018
--- /dev/null
+++ b/databases/php7-tarantool/Makefile
@@ -0,0 +1,24 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tarantool
+PORTVERSION= 0.3.0
+PORTREVISION= 1
+CATEGORIES= databases
+PKGNAMEPREFIX= php7-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PECL PHP driver for Tarantool
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= php:ext
+
+CONFIGURE_ARGS= --with-tarantool
+IGNORE_WITH_PHP=56
+
+USE_GITHUB= yes
+GH_PROJECT= ${PORTNAME}-php
+
+.include <bsd.port.mk>
diff --git a/databases/php7-tarantool/distinfo b/databases/php7-tarantool/distinfo
new file mode 100644
index 000000000000..9f5aad1d3486
--- /dev/null
+++ b/databases/php7-tarantool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519681756
+SHA256 (tarantool-tarantool-php-0.3.0_GH0.tar.gz) = 4d37d93e1553f6ce18ac09ecb975a9b7234bfeb75360959c44b98b28d64b93ba
+SIZE (tarantool-tarantool-php-0.3.0_GH0.tar.gz) = 684950
diff --git a/databases/php7-tarantool/pkg-descr b/databases/php7-tarantool/pkg-descr
new file mode 100644
index 000000000000..7e2d108603b3
--- /dev/null
+++ b/databases/php7-tarantool/pkg-descr
@@ -0,0 +1,3 @@
+PECL PHP driver for Tarantool
+
+WWW: https://github.com/tarantool/tarantool-php