aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/ganyremote/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/ganyremote/Makefile')
-rw-r--r--deskutils/ganyremote/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/deskutils/ganyremote/Makefile b/deskutils/ganyremote/Makefile
new file mode 100644
index 000000000000..7b20f9051826
--- /dev/null
+++ b/deskutils/ganyremote/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ganyremote
+# Date created: 08 November 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ganyremote
+PORTVERSION= 5.5.1
+CATEGORIES= deskutils comms gnome
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= anyremote
+
+MAINTAINER= ports@logvinov.com
+COMMENT= GNOME frontend for anyRemote
+
+RUN_DEPENDS= anyremote:${PORTSDIR}/comms/anyremote
+
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+USE_GNOME= pygtk2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PORTDOCS= AUTHORS COPYING README ChangeLog
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|usepybluez = True|usepybluez = False|' \
+ -e '/initVerify()$$/d' ${WRKSRC}/${PORTNAME}
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/doc\/${PORTNAME}/d' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>