aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gnome-blog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-blog/Makefile')
-rw-r--r--deskutils/gnome-blog/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/deskutils/gnome-blog/Makefile b/deskutils/gnome-blog/Makefile
new file mode 100644
index 000000000000..452effc08128
--- /dev/null
+++ b/deskutils/gnome-blog/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gnomeblog
+# Date created: 20 September 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomeblog
+PORTVERSION= 0.7
+CATEGORIES= deskutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-blog/0.7
+DISTNAME= gnome-blog-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME app to post to blogs
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/libs"
+
+.include <bsd.port.mk>