aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/libopensync-plugin-python-devel/Makefile11
-rw-r--r--deskutils/msynctool-devel/Makefile2
2 files changed, 8 insertions, 5 deletions
diff --git a/deskutils/libopensync-plugin-python-devel/Makefile b/deskutils/libopensync-plugin-python-devel/Makefile
index 636b107678b6..beb235d9ca95 100644
--- a/deskutils/libopensync-plugin-python-devel/Makefile
+++ b/deskutils/libopensync-plugin-python-devel/Makefile
@@ -19,8 +19,10 @@ LIB_DEPENDS= opensync.1:${PORTSDIR}/devel/libopensync
CONFLICTS= libopensync-plugin-python-0.2*
+BROKEN= fails to build with recent libopensync
+
USE_BZIP2= yes
-USES= cmake
+USES= cmake:outsource
USE_PYTHON= yes
USE_GNOME= pkgconfig
CMAKE_ARGS+= -Wno-dev \
@@ -32,9 +34,10 @@ CMAKE_ARGS+= -Wno-dev \
OS_PLUGIN_DIR= ${PREFIX}/lib/opensync-1.0/plugins
OS_PYPLUGIN_DIR=${PREFIX}/lib/opensync-1.0/python-plugins
-pre-patch:
- @${REINPLACE_CMD} -e "s|MESSAGE|# MESSAGE|" \
- ${WRKSRC}/cmake/modules/MacroEnsureOutOfSourceBuild.cmake
+post-patch:
+# Help find opensync, which is apparently renamed in ports
+ ${REINPLACE_CMD} -e "s,opensync-1.0,libopensync,g" \
+ ${WRKSRC}/cmake/modules/FindOpenSync.cmake
do-install:
${MKDIR} -p ${OS_PLUGIN_DIR} ${OS_PYPLUGIN_DIR}
diff --git a/deskutils/msynctool-devel/Makefile b/deskutils/msynctool-devel/Makefile
index 627acb11640f..65df8af2a68e 100644
--- a/deskutils/msynctool-devel/Makefile
+++ b/deskutils/msynctool-devel/Makefile
@@ -21,7 +21,7 @@ USE_PKGCONFIG= build
PLIST_FILES= bin/${PORTNAME}
-BROKEN= failes to build
+BROKEN= fails to build with recent libopensync
post-patch:
# Help find opensync, which is apparently renamed in ports