aboutsummaryrefslogtreecommitdiffstats
path: root/devel/android-tools-fastboot-devel/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/android-tools-fastboot-devel/files/Makefile')
-rw-r--r--devel/android-tools-fastboot-devel/files/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/devel/android-tools-fastboot-devel/files/Makefile b/devel/android-tools-fastboot-devel/files/Makefile
index ecfacc04a503..6aea6bb27ec3 100644
--- a/devel/android-tools-fastboot-devel/files/Makefile
+++ b/devel/android-tools-fastboot-devel/files/Makefile
@@ -49,6 +49,7 @@ SRCS+= wipe.c
# required by fastboot
.PATH: ${.CURDIR}/../libcutils
+SRCS+= android_get_control_file.cpp
SRCS+= ../libcutils/sockets.cpp
SRCS+= socket_inaddr_any_server_unix.c
SRCS+= socket_network_client_unix.c
@@ -57,13 +58,17 @@ CPPFLAGS.sockets.cpp+= -o ${.TARGET} # XXX pre-r279980
# required by base and libutils
.PATH: ${.CURDIR}/../liblog
+SRCS+= config_read.c
SRCS+= config_write.c
SRCS+= fake_log_device.c
SRCS+= fake_writer.c
+SRCS+= local_logger.c
SRCS+= logger_lock.c
SRCS+= logger_name.c
SRCS+= logger_write.c
-CPPFLAGS.config_write.c+= -DFAKE_LOG_DEVICE=1
+SRCS+= logprint.c
+SRCS+= stderr_write.c
+SRCS+= test_utils.cpp
# required by ext4_utils
.PATH: ${.CURDIR}/../libselinux/src
@@ -85,7 +90,7 @@ SRCS+= output_file.c
SRCS+= sparse.c
SRCS+= sparse_crc32.c
SRCS+= sparse_err.c
-SRCS+= sparse_read.c
+SRCS+= sparse_read.cpp
# required by libziparchive
.PATH: ${.CURDIR}/../libutils
@@ -97,18 +102,19 @@ SRCS+= zip_archive.cc
REVISION?= $$(${GIT} rev-parse --short=12 HEAD 2>/dev/null || echo unknown)
-CPPFLAGS+= -DFASTBOOT_REVISION="\"${REVISION}-android\""
+CPPFLAGS+= -DFASTBOOT_VERSION="\"0.0.0-${REVISION}-android\""
CPPFLAGS+= -Doff64_t=off_t
CPPFLAGS+= -Dftruncate64=ftruncate
CPPFLAGS+= -Dlseek64=lseek
CPPFLAGS+= -Dmmap64=mmap
CPPFLAGS+= -Dpread64=pread
+CPPFLAGS+= -DFAKE_LOG_DEVICE=1
CPPFLAGS+= -I${.CURDIR}
CPPFLAGS+= -I${.CURDIR}/../include
CPPFLAGS+= -I${.CURDIR}/../adb
CPPFLAGS+= -I${.CURDIR}/../mkbootimg
CPPFLAGS+= -I${.CURDIR}/../base/include
-CPPFLAGS+= -I${.CURDIR}/../ext4_utils
+CPPFLAGS+= -I${.CURDIR}/../ext4_utils/include
CPPFLAGS+= -I${.CURDIR}/../f2fs_utils
CPPFLAGS+= -I${.CURDIR}/../libselinux/include
CPPFLAGS+= -I${.CURDIR}/../libsparse/include