aboutsummaryrefslogtreecommitdiffstats
path: root/devel/anjuta
diff options
context:
space:
mode:
Diffstat (limited to 'devel/anjuta')
-rw-r--r--devel/anjuta/Makefile28
-rw-r--r--devel/anjuta/distinfo6
-rw-r--r--devel/anjuta/pkg-plist32
3 files changed, 37 insertions, 29 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index e88abca27b35..e71b6f11533b 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -1,9 +1,7 @@
# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
-# $FreeBSD$
PORTNAME= anjuta
-PORTVERSION= 3.28.0
-PORTREVISION= 3
+PORTVERSION= 3.34.0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,6 +9,9 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Integrated Development Environment for C and C++
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= autogen:devel/autogen \
itstool:textproc/itstool
LIB_DEPENDS+= libpcre.so:devel/pcre \
@@ -48,6 +49,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-symbol-db-shm=/tmp \
--disable-packagekit \
--disable-neon \
+ --disable-vala \
--enable-compile-warnings=minimum \
--enable-introspection=yes
DOCSDIR= share/doc/libanjuta
@@ -77,11 +79,10 @@ GLIB_SCHEMAS= org.gnome.anjuta.cvs.gschema.xml \
org.gnome.anjuta.tools.gschema.xml
OPTIONS_SUB= yes
-OPTIONS_DEFINE= SVN DEVHELP VALA GLADE TERMINAL
-OPTIONS_DEFAULT=SVN DEVHELP VALA GLADE TERMINAL
+OPTIONS_DEFINE= SVN DEVHELP GLADE TERMINAL
+OPTIONS_DEFAULT=SVN DEVHELP GLADE TERMINAL
SVN_DESC= Subversion plugin
DEVHELP_DESC= Devhelp plugin
-VALA_DESC= Vala support
GLADE_DESC= Build glade plugin
TERMINAL_DESC= Build build-in terminal
@@ -104,26 +105,11 @@ DEVHELP_LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libdevhelp-3.so:devel/devhelp
DEVHELP_CONFIGURE_ENABLE= plugin-devhelp
-VALA_VER= 0.40
-VALA_BUILD_DEPENDS= vala>=${VALA_VER},1<${VALA_VER}.99,1:lang/vala
-VALA_RUN_DEPENDS= vala>=${VALA_VER},1<${VALA_VER}.99,1:lang/vala
-VALA_CONFIGURE_ENABLE= vala
-
post-patch:
@${REINPLACE_CMD} -e 's|"make|"gmake|g' \
${WRKSRC}/plugins/build-basic-autotools/plugin.c
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${PREFIX}|g' \
${WRKSRC}/libanjuta/anjuta-utils.c
- @${REINPLACE_CMD} -e 's|ac_ct_CXX" = "x"|CXX" = "x"|g' \
- -e 's|libvala-0.28|libvala-${VALA_VER}|g' \
- -e 's|valaver="-0.28"|valaver="-${VALA_VER}"|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|values.h|limits.h|g' \
- ${WRKSRC}/plugins/project-wizard/property.h \
- ${WRKSRC}/plugins/project-wizard/install.h
- @${REINPLACE_CMD} -e 's|-fprofile-arcs||g' \
- ${WRKSRC}/libanjuta/tests/Makefile.in \
- ${WRKSRC}/libanjuta/tests/Makefile.am
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${PREFIX}|g' \
${WRKSRC}/plugins/gdb/debugger.c
diff --git a/devel/anjuta/distinfo b/devel/anjuta/distinfo
index efeced4809bb..66b5d06c7fe5 100644
--- a/devel/anjuta/distinfo
+++ b/devel/anjuta/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536528098
-SHA256 (gnome3/anjuta-3.28.0.tar.xz) = b087b0a5857952d0edd24dae458616eb166a3257bc647d5279a9e71495544779
-SIZE (gnome3/anjuta-3.28.0.tar.xz) = 6382736
+TIMESTAMP = 1599980598
+SHA256 (gnome3/anjuta-3.34.0.tar.xz) = 42a93130ed3ee02d064a7094e94e1ffae2032b3f35a87bf441e37fc3bb3a148f
+SIZE (gnome3/anjuta-3.34.0.tar.xz) = 6420472
diff --git a/devel/anjuta/pkg-plist b/devel/anjuta/pkg-plist
index b8e2709062ca..bd2c08408f63 100644
--- a/devel/anjuta/pkg-plist
+++ b/devel/anjuta/pkg-plist
@@ -156,7 +156,6 @@ lib/anjuta/anjuta-starter.plugin
%%SVN%%lib/anjuta/anjuta-subversion.plugin
%%TERMINAL%%lib/anjuta/anjuta-terminal.plugin
lib/anjuta/anjuta-tools.plugin
-%%VALA%%lib/anjuta/anjuta-vala.plugin
lib/anjuta/dir-project.plugin
lib/anjuta/file-manager.plugin
lib/anjuta/git.plugin
@@ -179,7 +178,6 @@ lib/anjuta/libanjuta-indentation-python-style.so
lib/anjuta/libanjuta-jhbuild.so
lib/anjuta/libanjuta-language-cpp-java.so
lib/anjuta/libanjuta-language-support-python.so
-%%VALA%%lib/anjuta/libanjuta-language-vala.so
lib/anjuta/libanjuta-loader.so
lib/anjuta/libanjuta-message-view.so
lib/anjuta/libanjuta-parser-cxx.so
@@ -250,7 +248,6 @@ man/man1/anjuta.1.gz
%%DATADIR%%/glade/anjuta-symbol-db.ui
%%TERMINAL%%%%DATADIR%%/glade/anjuta-terminal-plugin.ui
%%DATADIR%%/glade/anjuta-tools.ui
-%%VALA%%%%DATADIR%%/glade/anjuta-vala.ui
%%DATADIR%%/glade/applogo.png
%%DATADIR%%/glade/appwizard.png
%%DATADIR%%/glade/file-manager.ui
@@ -480,7 +477,7 @@ share/doc/anjuta/ChangeLog
share/doc/anjuta/FUTURE
share/doc/anjuta/MAINTAINERS
share/doc/anjuta/NEWS
-share/doc/anjuta/README
+share/doc/anjuta/README.md
share/doc/anjuta/ROADMAP
share/doc/anjuta/ScintillaDoc.html
share/doc/anjuta/THANKS
@@ -792,6 +789,19 @@ share/help/ca/anjuta-manual/project-wizard-template.page
share/help/ca/anjuta-manual/run-parameters-dialog.page
share/help/ca/anjuta-manual/run-run.page
share/help/ca/anjuta-manual/widget-index.page
+share/help/cs/anjuta-build-tutorial/figures/autotools-process.png
+share/help/cs/anjuta-build-tutorial/figures/build_preferences.png
+share/help/cs/anjuta-build-tutorial/figures/compilation-stages.png
+share/help/cs/anjuta-build-tutorial/figures/configure-dialog.png
+share/help/cs/anjuta-build-tutorial/figures/configure-process.png
+share/help/cs/anjuta-build-tutorial/figures/library-add-pkgconfig.png
+share/help/cs/anjuta-build-tutorial/figures/library-add-properties.png
+share/help/cs/anjuta-build-tutorial/figures/new-project-basic.png
+share/help/cs/anjuta-build-tutorial/figures/new-project-message.png
+share/help/cs/anjuta-build-tutorial/figures/new-project-options.png
+share/help/cs/anjuta-build-tutorial/figures/new-project-select.png
+share/help/cs/anjuta-build-tutorial/figures/new-project-summary.png
+share/help/cs/anjuta-build-tutorial/index.docbook
share/help/cs/anjuta-faqs/editor-goto-error.page
share/help/cs/anjuta-faqs/editor-maximize.page
share/help/cs/anjuta-faqs/editor-scintilla.page
@@ -936,6 +946,19 @@ share/help/da/anjuta-manual/project-wizard-template.page
share/help/da/anjuta-manual/run-parameters-dialog.page
share/help/da/anjuta-manual/run-run.page
share/help/da/anjuta-manual/widget-index.page
+share/help/de/anjuta-build-tutorial/figures/autotools-process.png
+share/help/de/anjuta-build-tutorial/figures/build_preferences.png
+share/help/de/anjuta-build-tutorial/figures/compilation-stages.png
+share/help/de/anjuta-build-tutorial/figures/configure-dialog.png
+share/help/de/anjuta-build-tutorial/figures/configure-process.png
+share/help/de/anjuta-build-tutorial/figures/library-add-pkgconfig.png
+share/help/de/anjuta-build-tutorial/figures/library-add-properties.png
+share/help/de/anjuta-build-tutorial/figures/new-project-basic.png
+share/help/de/anjuta-build-tutorial/figures/new-project-message.png
+share/help/de/anjuta-build-tutorial/figures/new-project-options.png
+share/help/de/anjuta-build-tutorial/figures/new-project-select.png
+share/help/de/anjuta-build-tutorial/figures/new-project-summary.png
+share/help/de/anjuta-build-tutorial/index.docbook
share/help/de/anjuta-faqs/editor-goto-error.page
share/help/de/anjuta-faqs/editor-maximize.page
share/help/de/anjuta-faqs/editor-scintilla.page
@@ -2294,7 +2317,6 @@ share/pixmaps/anjuta/anjuta-symbol-db-plugin.svg
%%TERMINAL%%share/pixmaps/anjuta/anjuta-terminal-plugin.svg
share/pixmaps/anjuta/anjuta-tools-plugin-48.png
share/pixmaps/anjuta/anjuta-tools-plugin.svg
-%%VALA%%share/pixmaps/anjuta/anjuta-vala.png
share/pixmaps/anjuta/anjuta-watch-16.png
share/pixmaps/anjuta/anjuta-watch-24.png
share/pixmaps/anjuta/anjuta-watch.svg