aboutsummaryrefslogtreecommitdiffstats
path: root/devel/codeville/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/codeville/Makefile')
-rw-r--r--devel/codeville/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/devel/codeville/Makefile b/devel/codeville/Makefile
index 1e1b80affb83..4a45091907bc 100644
--- a/devel/codeville/Makefile
+++ b/devel/codeville/Makefile
@@ -10,22 +10,18 @@ MAINTAINER= portmaster@bsdforge.com
COMMENT= Anarchic control version system without unnecessary re-merges
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-NO_ARCH= yes
USES= python:2.7 tar:xz
USE_PYTHON= distutils autoplist
+NO_ARCH= yes
-PORTDOCS= LICENSE.txt
PORTEXAMPLES= cdvserver.conf.sample
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= EXAMPLES
-post-install:
-# examples
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
-# documentation
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>