aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvsd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cvsd/Makefile')
-rw-r--r--devel/cvsd/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/devel/cvsd/Makefile b/devel/cvsd/Makefile
index afe02e85b45b..c550a1654539 100644
--- a/devel/cvsd/Makefile
+++ b/devel/cvsd/Makefile
@@ -13,8 +13,6 @@ COMMENT= CVS pserver daemon
EXTRA_PATCHES= ${FILESDIR}/extra-cvsd-buildroot.in
USES= perl5
-BUILD_DEPENDS= cvs:${PORTSDIR}/devel/cvs
-RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libwrap
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
@@ -25,9 +23,17 @@ MAN8= cvsd.8 cvsd-buginfo.8 cvsd-buildroot.8 cvsd-passwd.8
PORTDOCS= FAQ NEWS README
PLIST_FILES= etc/cvsd/cvsd.conf.sample sbin/cvsd sbin/cvsd-buginfo \
sbin/cvsd-buildroot sbin/cvsd-passwd
-PLIST_DIRS= etc/cvsd
+PLIST_DIRSTRY= etc/cvsd
USE_RC_SUBR= cvsd
+OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} > 1000000
+BUILD_DEPENDS= cvs:${PORTSDIR}/devel/cvs
+RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cvsd ${PREFIX}/sbin/cvsd
.for f in cvsd-buginfo cvsd-buildroot cvsd-passwd
@@ -41,11 +47,9 @@ do-install:
.for FILE in ${MAN8}
${INSTALL_MAN} ${WRKSRC}/${FILE} ${MAN8PREFIX}/man/man8
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}