aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fuzzylite
diff options
context:
space:
mode:
Diffstat (limited to 'devel/fuzzylite')
-rw-r--r--devel/fuzzylite/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/devel/fuzzylite/Makefile b/devel/fuzzylite/Makefile
index 86625440b227..b7750c69d4e7 100644
--- a/devel/fuzzylite/Makefile
+++ b/devel/fuzzylite/Makefile
@@ -11,20 +11,17 @@ COMMENT= Fuzzy logic control library in C++
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-type-limits"
-
-USES= cmake compiler
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
USE_LDCONFIG= yes
-CMAKE_ARGS= -DFL_BUILD_STATIC:BOOL=OFF \
- -DFL_BUILD_TESTS:BOOL=OFF
+CMAKE_OFF= FL_BUILD_STATIC FL_BUILD_TESTS
CMAKE_SOURCE_PATH= ${WRKSRC}/${PORTNAME}
PLIST_SUB= SHLIB_VER=${DISTVERSION}
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 39
+.if ${COMPILER_TYPE} == clang
CFLAGS+= -Wno-error=varargs
.endif