aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glib20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/glib20/Makefile')
-rw-r--r--devel/glib20/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 2c4290392809..fb55b8177877 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -3,11 +3,11 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/glib20/Makefile,v 1.91 2006/10/05 06:55:34 mezz Exp $
+# $MCom: ports/devel/glib20/Makefile,v 1.105 2007/10/16 12:35:26 ahze Exp $
#
PORTNAME= glib
-PORTVERSION= 2.12.13
+PORTVERSION= 2.14.2
PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/},} \
@@ -28,6 +28,8 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
@@ -36,7 +38,8 @@ USE_GMAKE= yes
USE_PERL5= yes
CONFIGURE_ARGS= --enable-static --with-libiconv=gnu \
--disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
- --disable-man --without-xml-catalog
+ --disable-man --without-xml-catalog \
+ --with-pcre=system
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \