aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gvfs
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gvfs')
-rw-r--r--devel/gvfs/Makefile73
-rw-r--r--devel/gvfs/distinfo3
-rw-r--r--devel/gvfs/files/patch-Makefile.in11
-rw-r--r--devel/gvfs/files/patch-client_Makefile.in11
-rw-r--r--devel/gvfs/files/patch-client_gvfsfusedaemon.c12
-rw-r--r--devel/gvfs/files/patch-configure84
-rw-r--r--devel/gvfs/files/patch-daemon_gvfswritechannel.c10
-rw-r--r--devel/gvfs/files/patch-hal_ghalvolume.c14
-rw-r--r--devel/gvfs/pkg-descr6
-rw-r--r--devel/gvfs/pkg-plist112
10 files changed, 336 insertions, 0 deletions
diff --git a/devel/gvfs/Makefile b/devel/gvfs/Makefile
new file mode 100644
index 000000000000..d52baa3468e1
--- /dev/null
+++ b/devel/gvfs/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: gvfs
+# Date created: 2007-11-06
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/gvfs/Makefile,v 1.21 2008/03/18 16:16:48 mezz Exp $
+#
+
+PORTNAME= gvfs
+PORTVERSION= 0.2.1
+PORTREVISION= 1
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME virtual file system
+
+LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus \
+ hal.1:${PORTSDIR}/sysutils/hal \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gnome-keyring:${PORTSDIR}/security/gnome-keyring \
+ avahi-client.3:${PORTSDIR}/net/avahi-app
+RUN_DEPENDS= gnome-mount:${PORTSDIR}/sysutils/gnome-mount
+
+USE_BZIP2= yes
+USE_GNOME= glib20 gnomehack gnomeprefix intlhack gconf2
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-obexftp
+OPTIONS= FUSE "Enable fuse" on \
+ SAMBA "Enable Samba" on \
+ GPHOTO2 "Enable Gphoto 2 camera support" on
+# CDDA "Enable CDDA" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FUSE) && ${OSVERSION} >= 600000
+LIB_DEPENDS+= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+PLIST_SUB+= FUSE=""
+.else
+CONFIGURE_ARGS+= --disable-fuse
+PLIST_SUB+= FUSE="@comment "
+.endif
+
+.if defined(WITH_SAMBA)
+LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+PLIST_SUB+= SMB=""
+.else
+CONFIGURE_ARGS+= --disable-samba
+PLIST_SUB+= SMB="@comment "
+.endif
+
+#.if defined(WITH_CDDA)
+#LIB_DEPENDS+= cdio_paranoia.0:${PORTSDIR}/sysutils/libcdio
+#PLIST_SUB+= CDDA=""
+#.else
+CONFIGURE_ARGS+= --disable-cdda
+PLIST_SUB+= CDDA="@comment "
+#.endif
+
+.if defined(WITH_GPHOTO2)
+LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+PLIST_SUB+= GPHOTO2=""
+.else
+CONFIGURE_ARGS+= --disable-gphoto2
+PLIST_SUB+= GPHOTO2="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/gvfs/distinfo b/devel/gvfs/distinfo
new file mode 100644
index 000000000000..8449712a6c57
--- /dev/null
+++ b/devel/gvfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (gvfs-0.2.1.tar.bz2) = 039e796a721bb178dd1759af76be5c13
+SHA256 (gvfs-0.2.1.tar.bz2) = bb51a59ab302f156a4ea2ec359be015229432728a4091576267ad4ed6b7c847b
+SIZE (gvfs-0.2.1.tar.bz2) = 817139
diff --git a/devel/gvfs/files/patch-Makefile.in b/devel/gvfs/files/patch-Makefile.in
new file mode 100644
index 000000000000..7832811c4608
--- /dev/null
+++ b/devel/gvfs/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2008-02-11 20:04:47.000000000 -0500
++++ Makefile.in 2008-02-11 20:05:02.000000000 -0500
+@@ -60,7 +60,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
+ distclean-recursive maintainer-clean-recursive
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = common client daemon gconf po programs test hal
++DIST_SUBDIRS = common client daemon gconf po programs hal
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ distdir = $(PACKAGE)-$(VERSION)
+ top_distdir = $(distdir)
diff --git a/devel/gvfs/files/patch-client_Makefile.in b/devel/gvfs/files/patch-client_Makefile.in
new file mode 100644
index 000000000000..ffbfd5878dc1
--- /dev/null
+++ b/devel/gvfs/files/patch-client_Makefile.in
@@ -0,0 +1,11 @@
+--- client/Makefile.in.orig 2008-02-11 20:05:14.000000000 -0500
++++ client/Makefile.in 2008-02-11 20:05:42.000000000 -0500
+@@ -152,7 +152,7 @@ EXEEXT = @EXEEXT@
+ F77 = @F77@
+ FFLAGS = @FFLAGS@
+ FUSE_CFLAGS = @FUSE_CFLAGS@
+-FUSE_LIBS = @FUSE_LIBS@
++FUSE_LIBS = @FUSE_LIBS@ -lfuse
+ GCONF_CFLAGS = @GCONF_CFLAGS@
+ GCONF_LIBS = @GCONF_LIBS@
+ GETTEXT_PACKAGE = @GETTEXT_PACKAGE@
diff --git a/devel/gvfs/files/patch-client_gvfsfusedaemon.c b/devel/gvfs/files/patch-client_gvfsfusedaemon.c
new file mode 100644
index 000000000000..3733aa7e3cd9
--- /dev/null
+++ b/devel/gvfs/files/patch-client_gvfsfusedaemon.c
@@ -0,0 +1,12 @@
+--- client/gvfsfusedaemon.c.orig 2007-11-06 18:06:41.000000000 -0500
++++ client/gvfsfusedaemon.c 2007-11-06 18:07:30.000000000 -0500
+@@ -28,7 +28,9 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#ifdef __linux__
+ #include <sys/vfs.h>
++#endif
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <stdlib.h>
diff --git a/devel/gvfs/files/patch-configure b/devel/gvfs/files/patch-configure
new file mode 100644
index 000000000000..5187da5d4282
--- /dev/null
+++ b/devel/gvfs/files/patch-configure
@@ -0,0 +1,84 @@
+--- configure.orig 2008-02-25 16:48:49.000000000 -0500
++++ configure 2008-02-25 16:51:17.000000000 -0500
+@@ -24589,7 +24589,7 @@ if test "x$enable_http" != "xno"; then
+ msg_http=yes
+ fi
+
+- if test "x$msg_http" == "xyes"; then
++ if test "x$msg_http" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for HTTP" >&5
+@@ -24857,7 +24857,7 @@ if test "x$enable_cdda" != "xno"; then
+ msg_cdda=yes
+ fi
+
+- if test "x$msg_cdda" == "xyes"; then
++ if test "x$msg_cdda" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for CDDA" >&5
+@@ -25008,7 +25008,7 @@ if test "x$enable_fuse" != "xno"; then
+ msg_fuse=yes
+ fi
+
+- if test "x$msg_fuse" == "xyes"; then
++ if test "x$msg_fuse" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for FUSE" >&5
+@@ -25159,7 +25159,7 @@ if test "x$enable_gconf" != "xno"; then
+ msg_gconf=yes
+ fi
+
+- if test "x$msg_gconf" == "xyes"; then
++ if test "x$msg_gconf" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for GCONF" >&5
+@@ -25312,7 +25312,7 @@ if test "x$enable_hal" != "xno"; then
+ msg_hal=yes
+ fi
+
+- if test "x$msg_hal" == "xyes"; then
++ if test "x$msg_hal" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for HAL" >&5
+@@ -25494,7 +25494,7 @@ if test $ac_cv_lib_hal_libhal_get_all_de
+ have_hal_fast_init=yes
+ fi
+
+- if test "x$have_hal_fast_init" == "xyes"; then
++ if test "x$have_hal_fast_init" = "xyes"; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_HAL_FAST_INIT 1
+@@ -25540,13 +25540,16 @@ fi
+ *-linux*)
+ use_gphoto2=yes
+ ;;
++ *-freebsd*)
++ use_gphoto2=yes
++ ;;
+ *)
+ use_gphoto2=no
+ ;;
+ esac
+
+- if test "x$msg_gphoto2" == "xyes"; then
+- if test "x$use_gphoto2" == "xyes"; then
++ if test "x$msg_gphoto2" = "xyes"; then
++ if test "x$use_gphoto2" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for GPHOTO2" >&5
+@@ -25702,7 +25705,7 @@ if test "x$enable_keyring" != "xno"; the
+ msg_keyring=yes
+ fi
+
+- if test "x$msg_keyring" == "xyes"; then
++ if test "x$msg_keyring" = "xyes"; then
+
+ pkg_failed=no
+ { echo "$as_me:$LINENO: checking for KEYRING" >&5
diff --git a/devel/gvfs/files/patch-daemon_gvfswritechannel.c b/devel/gvfs/files/patch-daemon_gvfswritechannel.c
new file mode 100644
index 000000000000..54c4216873e4
--- /dev/null
+++ b/devel/gvfs/files/patch-daemon_gvfswritechannel.c
@@ -0,0 +1,10 @@
+--- daemon/gvfswritechannel.c.orig 2007-12-22 18:50:10.000000000 -0500
++++ daemon/gvfswritechannel.c 2007-12-22 18:50:20.000000000 -0500
+@@ -30,6 +30,7 @@
+ #include <sys/un.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <string.h>
+
+ #include <glib.h>
+ #include <glib-object.h>
diff --git a/devel/gvfs/files/patch-hal_ghalvolume.c b/devel/gvfs/files/patch-hal_ghalvolume.c
new file mode 100644
index 000000000000..519718969441
--- /dev/null
+++ b/devel/gvfs/files/patch-hal_ghalvolume.c
@@ -0,0 +1,14 @@
+--- hal/ghalvolume.c.orig 2008-02-25 16:51:39.000000000 -0500
++++ hal/ghalvolume.c 2008-02-25 16:52:00.000000000 -0500
+@@ -550,7 +550,11 @@ g_hal_volume_new (GVolumeMonitor *volu
+ return NULL;
+
+ /* TODO: other OS'es? Will address this with DK aka HAL 2.0 */
++#ifdef __FreeBSD__
++ device_path = hal_device_get_property_string (drive_device, "freebsd.device_file");
++#else
+ device_path = hal_device_get_property_string (drive_device, "linux.device_file");
++#endif
+ if (strlen (device_path) == 0)
+ device_path = NULL;
+
diff --git a/devel/gvfs/pkg-descr b/devel/gvfs/pkg-descr
new file mode 100644
index 000000000000..f6ea31130f4b
--- /dev/null
+++ b/devel/gvfs/pkg-descr
@@ -0,0 +1,6 @@
+GVFS allows applications and users to treat any number of file system
+concepts as a part of the local filesystem. With GVFS, filesystems across
+the internet, on connected devices, and in multiple formats are as simple
+to access (and write code for) as any directory on the local machine.
+
+WWW: http://www.gnome.org/
diff --git a/devel/gvfs/pkg-plist b/devel/gvfs/pkg-plist
new file mode 100644
index 000000000000..f1b4305b9c05
--- /dev/null
+++ b/devel/gvfs/pkg-plist
@@ -0,0 +1,112 @@
+bin/gvfs-cat
+bin/gvfs-copy
+bin/gvfs-info
+bin/gvfs-less
+bin/gvfs-ls
+bin/gvfs-mkdir
+bin/gvfs-monitor-dir
+bin/gvfs-monitor-file
+bin/gvfs-mount
+bin/gvfs-move
+bin/gvfs-open
+bin/gvfs-rename
+bin/gvfs-rm
+bin/gvfs-save
+bin/gvfs-trash
+bin/gvfs-tree
+etc/profile.d/gvfs-bash-completion.sh
+include/gvfs-client/gvfs/gvfsurimapper.h
+include/gvfs-client/gvfs/gvfsuriutils.h
+lib/gio/modules/libgiogconf.la
+lib/gio/modules/libgiogconf.so
+lib/gio/modules/libgiohal-volume-monitor.la
+lib/gio/modules/libgiohal-volume-monitor.so
+lib/gio/modules/libgvfsdbus.la
+lib/gio/modules/libgvfsdbus.so
+lib/libgvfscommon.la
+lib/libgvfscommon.so
+lib/libgvfscommon.so.0
+%%FUSE%%libexec/gvfs-fuse-daemon
+libexec/gvfsd
+libexec/gvfsd-archive
+libexec/gvfsd-burn
+libexec/gvfsd-computer
+libexec/gvfsd-dav
+libexec/gvfsd-dnssd
+libexec/gvfsd-ftp
+%%GPHOTO2%%libexec/gvfsd-gphoto2
+libexec/gvfsd-http
+libexec/gvfsd-localtest
+libexec/gvfsd-network
+libexec/gvfsd-sftp
+%%SMB%%libexec/gvfsd-smb
+%%SMB%%libexec/gvfsd-smb-browse
+libexec/gvfsd-trash
+share/dbus-1/services/gvfs-daemon.service
+share/gvfs/mounts/archive.mount
+share/gvfs/mounts/burn.mount
+share/gvfs/mounts/computer.mount
+share/gvfs/mounts/dav.mount
+share/gvfs/mounts/dns-sd.mount
+share/gvfs/mounts/ftp.mount
+%%GPHOTO2%%share/gvfs/mounts/gphoto2.mount
+share/gvfs/mounts/http.mount
+share/gvfs/mounts/localtest.mount
+share/gvfs/mounts/network.mount
+share/gvfs/mounts/sftp.mount
+%%SMB%%share/gvfs/mounts/smb-browse.mount
+%%SMB%%share/gvfs/mounts/smb.mount
+share/gvfs/mounts/trash.mount
+share/locale/ar/LC_MESSAGES/gvfs.mo
+share/locale/be@latin/LC_MESSAGES/gvfs.mo
+share/locale/bn_IN/LC_MESSAGES/gvfs.mo
+share/locale/ca/LC_MESSAGES/gvfs.mo
+share/locale/cs/LC_MESSAGES/gvfs.mo
+share/locale/da/LC_MESSAGES/gvfs.mo
+share/locale/de/LC_MESSAGES/gvfs.mo
+share/locale/el/LC_MESSAGES/gvfs.mo
+share/locale/en_GB/LC_MESSAGES/gvfs.mo
+share/locale/es/LC_MESSAGES/gvfs.mo
+share/locale/eu/LC_MESSAGES/gvfs.mo
+share/locale/fi/LC_MESSAGES/gvfs.mo
+share/locale/fr/LC_MESSAGES/gvfs.mo
+share/locale/gl/LC_MESSAGES/gvfs.mo
+share/locale/he/LC_MESSAGES/gvfs.mo
+share/locale/hi/LC_MESSAGES/gvfs.mo
+share/locale/hu/LC_MESSAGES/gvfs.mo
+share/locale/it/LC_MESSAGES/gvfs.mo
+share/locale/ja/LC_MESSAGES/gvfs.mo
+share/locale/ko/LC_MESSAGES/gvfs.mo
+share/locale/lt/LC_MESSAGES/gvfs.mo
+share/locale/mk/LC_MESSAGES/gvfs.mo
+share/locale/ml/LC_MESSAGES/gvfs.mo
+share/locale/mr/LC_MESSAGES/gvfs.mo
+share/locale/nb/LC_MESSAGES/gvfs.mo
+share/locale/nl/LC_MESSAGES/gvfs.mo
+share/locale/pa/LC_MESSAGES/gvfs.mo
+share/locale/pl/LC_MESSAGES/gvfs.mo
+share/locale/pt/LC_MESSAGES/gvfs.mo
+share/locale/pt_BR/LC_MESSAGES/gvfs.mo
+share/locale/ru/LC_MESSAGES/gvfs.mo
+share/locale/sk/LC_MESSAGES/gvfs.mo
+share/locale/sl/LC_MESSAGES/gvfs.mo
+share/locale/sv/LC_MESSAGES/gvfs.mo
+share/locale/ta/LC_MESSAGES/gvfs.mo
+share/locale/th/LC_MESSAGES/gvfs.mo
+share/locale/tr/LC_MESSAGES/gvfs.mo
+share/locale/uk/LC_MESSAGES/gvfs.mo
+share/locale/zh_CN/LC_MESSAGES/gvfs.mo
+share/locale/zh_HK/LC_MESSAGES/gvfs.mo
+share/locale/zh_TW/LC_MESSAGES/gvfs.mo
+@dirrm %%DATADIR%%/mounts
+@dirrm %%DATADIR%%
+@dirrm include/gvfs-client/gvfs
+@dirrm include/gvfs-client
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin