aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kdebindings4-python-krosspython/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kdebindings4-python-krosspython/Makefile')
-rw-r--r--devel/kdebindings4-python-krosspython/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/devel/kdebindings4-python-krosspython/Makefile b/devel/kdebindings4-python-krosspython/Makefile
index fe726afb5263..ef39330ee7f7 100644
--- a/devel/kdebindings4-python-krosspython/Makefile
+++ b/devel/kdebindings4-python-krosspython/Makefile
@@ -5,18 +5,28 @@
# $FreeBSD$
#
-PORTNAME= kdebindings
+PORTNAME= krosspython
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= devel kde python
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}kdebindings-
+DISTNAME= kross-interpreters-${PORTVERSION}
+DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Kross Python scripting library
-BINDLANG= python
-BINDMODULE= krosspython
-
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_PYTHON= 2.5+
-QT_COMPONENTS= gui
+USE_QT_VER= 4
+QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build
+USE_BZIP2= yes
+DISTINFO_FILE= ${PORTSDIR}/devel/kdebindings4-kross-interpreters/distinfo
+USE_CMAKE= yes
+CMAKE_ARGS+= -DBUILD_falcon:BOOL=FALSE \
+ -DBUILD_ruby:BOOL=FALSE \
+ -DBUILD_java:BOOL=FALSE
+MAKE_JOBS_SAFE= yes
-.include "${.CURDIR}/../../devel/kdebindings4/files/Makefile.kdebindings"
.include <bsd.port.mk>